Aller au contenu principal

Annexe F. Changements par Rapport à RFC 2461 (Changes from RFC 2461)

Cette annexe résume les changements entre RFC 4861 et son prédécesseur, RFC 2461.

F.1. Changements Majeurs​

  • Références mises à jour (RFC 2463 → RFC 4443, RFC 2373 → RFC 4291)
  • Clarifications sur la détection d'inaccessibilité des voisins
  • Section Considérations de Sécurité considérablement élargie

F.2. Corrections Techniques​

  • Clarification du traitement des RA avec Router Lifetime zéro
  • Clarification du traitement des messages Redirect
  • Clarification des options Prefix Information

F.3. Changements Éditoriaux​

  • Cohérence améliorée de la terminologie
  • Diagrammes de format de message mis à jour

F.4. Changements Comportementaux​

  • Règles clarifiées pour le flag IsRouter
  • Génération d'adresse link-local mise à jour
  • Clarifications DAD mineures

F.5. Nouvelles Sections​

  • Section 12 : Considérations de Renumbering
  • Algorithme d'envoi conceptuel amélioré

F.6. Contenu Supprimé ou Déprécié​

  • Certains exemples spécifiques à l'implémentation supprimés

F.7. Considérations IANA​

  • Section mise à jour pour refléter les procédures IANA actuelles

F.8. Constantes de Protocole​

  • Ajustements mineurs des définitions

F.9. Impact sur les Implémentations​

Compatibilité: RFC 4861 est largement rétrocompatible avec RFC 2461 Migration: Déploiement incrémental possible

F.10. Résumé des Changements Clés​

  1. Guidage de sécurité amélioré
  2. Comportement NUD clarifié
  3. Références normatives mises à jour
  4. Considérations de renumbering
  5. Améliorations éditoriales