4. Considerations with Special Types
4. Considerations with Special Types (Considérations avec les types spéciaux)
Ceci est un résumé des actions pour divers types. La plupart de ces dispositions sont dues au fait que les RR d'un type peuvent ou non coexister. Certains sont simplement des observations.
4.1 SOA RRSet at a Wildcard Domain Name
Un nom de domaine joker possédant un ensemble RR SOA signifie que le domaine est au sommet de la zone et est un nom de domaine joker. La possession d'enregistrements SOA par un nom de domaine joker a un effet non défini. Pour éviter une situation où les jokers sont utilisés pour synthétiser des enregistrements SOA, un enregistrement SOA NE DOIT PAS être le seul enregistrement à un nom de domaine joker.
4.2 NS RRSet at a Wildcard Domain Name
Un nom de domaine joker n'est pas un point de délégation. La synthèse d'un ensemble RR NS n'a pas été définie. Certains travaux DNS antérieurs ont considéré permettre la synthèse de points de délégation, mais cette possibilité a été rejetée.
4.3 CNAME RRSet at a Wildcard Domain Name
L'interaction des CNAME et des jokers est mise à jour dans la section 3.3.3 de ce document. Un ensemble RR CNAME à un nom de domaine joker ne peut être utilisé que pour synthétiser des RR CNAME.
4.4 DNAME RRSet at a Wildcard Domain Name
La possession d'un ensemble RR DNAME [RFC2672] par un nom de domaine joker représente une menace pour la cohérence du DNS et doit être évitée ou carrément rejetée.
4.5 SRV RRSet at a Wildcard Domain Name
Il n'y a pas de raison particulière de traiter les ensembles RR SRV [RFC2782] autrement que les autres types d'ensembles RR. La synthèse d'un ensemble RR SRV est donc possible.
4.6 DS RRSet at a Wildcard Domain Name
La possession d'un ensemble RR DS [RFC3658] par un nom de domaine joker n'est pas définie. Un enregistrement DS à un nom de domaine joker aurait l'effet de déléguer un domaine qui n'existe pas encore. Cela est contraire à l'esprit des enregistrements DS et doit être évité.
4.7 NSEC RRSet at a Wildcard Domain Name
La possession d'un ensemble RR NSEC [RFC4034] par un nom de domaine joker n'est pas définie. Un enregistrement NSEC à un nom de domaine joker fournirait une preuve d'inexistence pour les noms sous le nom de domaine joker, ce qui contredirait l'objectif d'un nom de domaine joker. Cela doit être évité.
4.8 RRSIG at a Wildcard Domain Name
La possession d'un enregistrement RRSIG [RFC4034] par un nom de domaine joker n'est pas définie. Un enregistrement RRSIG à un nom de domaine joker fournirait une signature pour un nom qui n'existe pas encore. Cela doit être évité.
4.9 Empty Non-terminal Wildcard Domain Name
La possession d'un nom de domaine joker qui est un non-terminal vide (c'est-à-dire sans enregistrements autres que le nom de domaine joker lui-même) n'est pas définie. Un tel nom se comporterait comme un non-terminal vide s'il n'avait pas d'enregistrements; cependant, puisqu'il s'agit d'un nom de domaine joker, il est censé synthétiser des enregistrements. Le comportement d'un tel nom est donc ambigu et doit être évité.