Aller au contenu principal

RFC 2818 - HTTP sur TLS (HTTPS)

  • Statut: Informational
  • Publié: May 2000
  • Stream: IETF
  • Remplacé par: RFC9110
  • Errata: Pas d'errata

Résumé (Abstract)​

Ce mémo décrit comment utiliser TLS pour sécuriser les connexions HTTP sur Internet. La pratique actuelle consiste à superposer HTTP sur SSL (le prédécesseur de TLS), en distinguant le trafic sécurisé du trafic non sécurisé par l'utilisation d'un port serveur différent. Ce document documente cette pratique en utilisant TLS. Un document compagnon décrit une méthode pour utiliser HTTP/TLS sur le même port que le HTTP normal [RFC2817].

Importance​

RFC 2818 est la pierre angulaire de la sécurité Web :

  • 🔒 Définit le mécanisme de base de HTTPS
  • 🌐 Fondement de la sécurité pour tous les sites Web modernes
  • 🔑 Validation des certificats et vérification d'identité
  • ⚡ Établissement et fermeture de connexion sécurisée

Table of Contents​