Zum Hauptinhalt springen

RFC 5462 - Multiprotocol Label Switching (MPLS) Label Stack Entry: "EXP" Field Renamed to "Traffic Class" Field

  • Status: Proposed Standard
  • Veröffentlicht: February 2009
  • Stream: IETF
  • Aktualisiert: RFC 3032, RFC 3270, RFC 3272, RFC 3443, RFC 3469, RFC 3564, RFC 3985, RFC 4182, RFC 4364, RFC 4379, RFC 4448, RFC 4761, RFC 5129
  • Errata: RFC-Editor-Errata

Status dieses Memos​

Dieses Dokument spezifiziert ein Protokoll auf dem Internet-Standardisierungsweg für die Internetgemeinschaft und bittet um Diskussion und Verbesserungsvorschläge. Der aktuelle Stand und Standardisierungsstatus dieses Protokolls ist der jeweils gültigen Ausgabe der „Internet Official Protocol Standards“ (STD 1) zu entnehmen. Dieses Memo darf uneingeschränkt verbreitet werden.

Urheberrechtshinweis​

Copyright (c) 2009 IETF Trust und die als Autoren des Dokuments genannten Personen. Alle Rechte vorbehalten.

Dieses Dokument unterliegt BCP 78 und den zum Veröffentlichungszeitpunkt geltenden rechtlichen Bestimmungen des IETF Trust für IETF-Dokumente (http://trustee.ietf.org/license-info). Diese Bestimmungen sollten sorgfältig gelesen werden, da sie die Rechte und Einschränkungen in Bezug auf dieses Dokument beschreiben.

Zusammenfassung​

Die frühen Dokumente zu Multiprotocol Label Switching (MPLS) legten die Form eines MPLS-Label-Stack-Eintrags fest. Dazu gehört ein drei Bit breites Feld, das als „EXP-Feld“ bezeichnet wird. Seine genaue Verwendung wurde in diesen Dokumenten nicht definiert; es hieß lediglich, das Feld sei „für experimentelle Verwendung reserviert“.

Obwohl das EXP-Feld als „Class of Service“-Feld (CoS) gedacht war, bezeichneten diese frühen Dokumente es nicht als CoS-Feld, da seine Verwendung damals noch nicht als ausreichend definiert galt. Heute legen mehrere Standarddokumente seine Nutzung als CoS-Feld fest.

Um Missverständnisse über die zulässige Verwendung zu vermeiden, wurde eine Umbenennung des Feldes zunehmend notwendig. Dieses Dokument benennt es in „Traffic Class field“ („TC-Feld“) um und aktualisiert dabei zugleich die Dokumente, welche die gegenwärtige Verwendung des EXP-Feldes festlegen.

Inhaltsverzeichnis​

Anschriften der Autoren​

Loa Andersson, Acreo AB
E-Mail: [email protected]

Rajiv Asati, Cisco Systems
E-Mail: [email protected]