跳到主要内容

9. IANA 考虑

本节描述 IANA 已完成的操作.

9.1. "Email Authentication Methods" 注册表更新​

IANA 已在 "Email Authentication Parameters" 注册表组内的 "Email Authentication Methods" 注册表中, 注册由电子邮件认证方法评估的电子邮件消息属性.

每项注册包括 authentication method, 定义该 authentication method 的规范, property type (ptype), property, 该 property 的值, property 状态以及版本. ptype 是同一注册表组内 "Email Authentication Property Types" 注册表条目中的 ptype 值之一. property 状态为 "active" 或 "deprecated" 之一. 指定专家需要确认所提供规范充分描述了该 property 及其评估方法, 并清楚说明 Domain Owner 和 Mail Receiver 如何在 DMARC 上下文中使用它们.

IANA 已将注册过程从 Expert Review 改为 Specification Required [RFC8126], 并将本文列为该注册表的附加引用. IANA 已按如下方式更新该注册表:

MethodDefinitionptypePropertyValueStatusVersion
dmarcRFC 9989headerfromRFC5322.From header field 的 domain 部分active1
dmarcRFC 9989policydmarc经评估并在处理策略选项后已应用或将应用的 DMARC policy. Must be "none", "quarantine" 或 "reject".active1

表 3: "Email Authentication Methods" 注册表更新.

9.2. "Email Authentication Result Names" 注册表更新​

DMARC 的结果代码由 IANA 注册在 "Email Authentication Parameters" 注册表组内的 "Email Authentication Result Names" 注册表中.

每项注册包括 auth method, code, 定义该 code 的规范, 以及 code 状态. code 状态为 "active" 或 "deprecated" 之一. 注意, 此处包含 "Description" 字段仅供读者参考, 不出现在 IANA 注册表中. 指定专家需要确认所提供规范充分描述了结果代码, 并清楚说明 Domain Owner 和 Mail Receiver 如何在 DMARC 上下文中使用它.

IANA 已将注册过程从 Expert Review 改为 Specification Required [RFC8126], 并将本文列为该注册表的附加引用. IANA 已按如下方式更新该注册表, 将对 [RFC7489] 的引用替换为对本文的引用:

Auth Method(s)CodeSpecificationStatusDescription
dmarcfailRFC 9989activeAuthor Domain 存在 DMARC Policy Record, 但不存在具有 Identifier Alignment 的 Authenticated Identifier.
dmarcnoneRFC 9989activeAuthor Domain 不存在 DMARC Policy Record.
dmarcpassRFC 9989activeAuthor Domain 存在 DMARC Policy Record, 且存在具有 Identifier Alignment 的 Authenticated Identifier.
dmarcpermerrorRFC 9989activeDMARC evaluation 期间发生不可恢复的错误, 例如取回了格式不正确的 DMARC Policy Record. 之后再次尝试不太可能得到最终结果.
dmarctemperrorRFC 9989activeDMARC evaluation 期间发生可能具有瞬态性质的错误, 例如 DNS server 暂时不可达. 之后再次尝试可能得到最终结果.

表 4: "Email Authentication Result Names" 注册表更新.

9.3. "DMARC Tags" 注册表更新​

在 DMARC Policy Record 中作为 "tag-value" pair 一部分使用的 tag name, 由 IANA 注册在 "Domain-based Message Authentication, Reporting, and Conformance (DMARC)" 注册表组内的 "DMARC Tags" 注册表中.

仅为已经按满足 Specification Required [RFC8126] 条款的方式文档化的值分配条目. 每项注册包括 tag name, 定义该 tag 的规范, tag 状态, 以及 tag 简要描述. 指定专家需要确认所提供规范充分描述了该 tag, 并清楚说明 Domain Owner 和 Mail Receiver 如何在 DMARC 上下文中使用它. "status" 列为以下值之一:

  • "active", 表示该 tag 正由当前实现使用, 且其规范预期保持稳定.

  • "experimental", 表示该 tag 相对较新, 可能在某些当前实现中使用但未在其他实现中使用, 且其规范预期不会保持稳定.

  • "historic", 表示该 tag 被视为已弃用, 且预期不会在任何当前实现中使用.

为避免版本兼容性问题, 添加到 DMARC 规范中的 tag 应避免在符合先前规范的实现处理现有记录时改变其语义.

IANA 已将本文而非 [RFC7489] 列为该注册表的引用. IANA 已按如下方式更新该注册表, 包括新增 "t" 注册:

Tag NameReferenceStatusDescription
adkimRFC 9989activeDKIM Identifier Alignment mode
aspfRFC 9989activeSPF Identifier Alignment mode
foRFC 9989activeFailure reporting options
npRFC 9989active针对不存在子域所请求的 Domain Owner Assessment Policy
pRFC 9989active所请求的 Domain Owner Assessment Policy
pct[RFC7489]historicSampling rate
psdRFC 9989active指示 DMARC Policy Record 是否由 Public Suffix Domain 发布
rf[RFC7489]historicFailure reporting format(s)
ri[RFC7489]historicAggregate Reporting interval
ruaRFC 9989activeDMARC aggregate feedback report 的 Reporting URI
rufRFC 9989activemessage-specific DMARC failure report 的 Reporting URI
spRFC 9989active针对子域所请求的 Domain Owner Assessment Policy
tRFC 9989activeDMARC policy test mode
vRFC 9989activeDMARC specification version

表 5: "DMARC Tags" 注册表更新.

9.4. "DMARC Report Formats" 注册表更新​

DMARC failure reporting format 的名称由 IANA 注册在 "Domain-based Message Authentication, Reporting, and Conformance (DMARC)" 注册表组内的 "DMARC Report Formats" 注册表中.

仅为已经按满足 Specification Required [RFC8126] 条款的方式文档化的值分配条目. 除对永久规范的引用外, 每项注册还包括 format name, format 状态, 以及 format 简要描述. 指定专家需要确认所提供规范充分描述了该 report format, 并清楚说明 Domain Owner 和 Mail Receiver 如何在 DMARC 上下文中使用它. "status" 列为以下值之一:

  • "active", 表示该 format 正由当前实现使用, 且其规范预期保持稳定.

  • "experimental", 表示该 format 相对较新, 可能在某些当前实现中使用但未在其他实现中使用, 且其规范预期不会保持稳定.

  • "historic", 表示该 format 被视为已弃用, 且预期不会在任何当前实现中使用.

IANA 已将本文而非 [RFC7489] 列为该注册表的引用. IANA 已按如下方式更新该注册表:

Format NameReferenceStatusDescription
afrfRFC 9989activeAuthentication Failure Reporting Format, 见 [RFC6591]

表 6: "DMARC Report Formats" 注册表更新.

9.5. "Underscored and Globally Scoped DNS Node Names" 注册表更新​

以下划线字符开头且具有全局作用域的 DNS Resource Record (RR) 名称, 按 [RFC8552] 规定, 由 IANA 注册在 "Domain Name System (DNS) Parameters" 注册表组内的 "Underscored and Globally Scoped DNS Node Names" 注册表中.

除对永久规范的引用外, 每项注册还包含 DNS RR type 和 Node Name. 指定专家需要确认所提供规范充分描述了该 Node Name, 并清楚说明 Domain Owner 和 Mail Receiver 如何在 DMARC 上下文中使用它.

IANA 已更新以下条目的引用, 使其指向本文而非 [RFC7489]:

RR Type_NODE NAMEReference
TXT_dmarcRFC 9989

表 7: "Underscored and Globally Scoped DNS Node Names" 注册表更新.