跳到主要内容

12. IANA 考量

根据本文档, IANA 已为协议运行 Control phase 中的 Test Setup 交换分配了一个 UDP 端口号, 并为 UDPSTP 创建了新的注册表组.

12.1. 新的 User Port Number 分配​

IANA 已在 "Service Name and Transport Protocol Port Number Registry" 中注册以下服务名称:

Service Name:  udpstp
Port Number: 24601
Transport Protocol: udp
Description: UDP-based IP-Layer Capacity and Performance Measurement
protocol
Assignee: IESG <[email protected]>
Contact: IETF Chair <[email protected]>
Reference: RFC 9946

该协议使用 IP-Layer Unicast. 分配单一端口号的目的是, 在客户端和服务器协商动态端口之前, 帮助防火墙以及其他基于端口的系统配置访问控制.

12.2. 新的 KeyTable KDF​

IANA 已向 "KeyTable KDFs" 注册表添加以下 KDF 条目, 见 https://www.iana.org/assignments/keytable:

     +==============+=============================+===========+
| KDF | Description | Reference |
+==============+=============================+===========+
| HMAC-SHA-256 | HMAC using the SHA-256 hash | [RFC6234] |
+--------------+-----------------------------+-----------+

表 1: KeyTable KDFs 注册表

12.3. 新的 UDPSTP 注册表组​

IANA 已在名为 "UDP Speed Test Protocol (UDPSTP)" 的新注册表组下创建以下小节中的注册表.

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下添加以下说明:

|  Note: Values reserved for Experimental Use are not expected to be
| used on the Internet but are expected to be used for experiments
| that are confined to closed environments.

12.3.1. PDU Identifier 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "PDU Identifier" 注册表. 每个 UDPSTP PDU 都包含一个二八位字节的 pduId 字段, 用于标识随后 PDU 的角色和格式. 此注册表中的代码点按照表 2 所述的注册程序 [RFC8126] 分配.

             +===============+=========================+
| Range | Registration Procedures |
+===============+=========================+
| 0x0000 | Reserved |
+---------------+-------------------------+
| 0x0001-0x7F00 | Specification Required |
+---------------+-------------------------+
| 0x7F01-0x7FE0 | Experimental Use |
+---------------+-------------------------+
| 0x7FE1-0x7FFF | Private Use |
+---------------+-------------------------+
| 0x8000-0xFFFE | IETF Review |
+---------------+-------------------------+
| 0xFFFF | Reserved |
+---------------+-------------------------+

表 2: PDU Identifier 注册表的注册程序

IANA 已在 "PDU Identifier" 注册表中分配以下值:

    +===============+===============================+===========+
| Value | Description | Reference |
+===============+===============================+===========+
| 0x0000 | Reserved | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0x7F01-0x7FE0 | Reserved for Experimental Use | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0x7FE1-0x7FFF | Reserved for Private Use | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xACE1 | Test Setup PDU | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xACE2 | Test Activation PDU | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xBEEF | Load PDU | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xDEAD | Null PDU | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xFEED | Status Feedback PDU | RFC 9946 |
+---------------+-------------------------------+-----------+
| 0xFFFF | Reserved | RFC 9946 |
+---------------+-------------------------------+-----------+

表 3: PDU Identifier 注册表的初始值

12.3.2. Protocol Version 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Protocol Version" 注册表. UDPSTP Test Setup Request, Test Setup Response 和 Test Activation Request PDU 包含一个二八位字节的 protocolVer 字段, 用于标识正在使用的协议版本. 此注册表中的代码点按照表 4 所述的注册程序 [RFC8126] 分配.

              +=============+=========================+
| Range | Registration Procedures |
+=============+=========================+
| 0-19 | Reserved |
+-------------+-------------------------+
| 20-40960 | IETF Review |
+-------------+-------------------------+
| 40961-53248 | Specification Required |
+-------------+-------------------------+
| 53249-65534 | Experimental Use |
+-------------+-------------------------+
| 65535 | Reserved |
+-------------+-------------------------+

表 4: Protocol Version 注册表的注册程序

IANA 已在 "Protocol Version" 注册表中分配十进制值 20, 如下所示:

                        +=======+===========+
| Value | Reference |
+=======+===========+
| 20 | RFC 9946 |
+-------+-----------+

表 5: Protocol Version 注册表的初始值

12.3.3. Test Setup PDU Modifier Bitmap 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Setup PDU Modifier Bitmap" 注册表. Test Setup PDU 布局包含 modifierBitmap 字段. 此注册表中的位图按照表 6 所述的注册程序 [RFC8126] 分配.

           +===================+=========================+
| Range | Registration Procedures |
+===================+=========================+
| 00000000-01111111 | IETF Review |
+-------------------+-------------------------+
| 10000000 | Reserved |
+-------------------+-------------------------+

表 6: Test Setup PDU Modifier Bitmap 注册表的注册程序

IANA 已在 "Test Setup PDU Modifier Bitmap" 注册表中分配以下位图值:

        +=======+===============================+===========+
| Value | Description | Reference |
+=======+===============================+===========+
| 0x00 | No modifications | RFC 9946 |
+-------+-------------------------------+-----------+
| 0x01 | Allow Jumbo datagram sizes | RFC 9946 |
| | above sending rates of 1 Gbps | |
+-------+-------------------------------+-----------+
| 0x02 | Use Traditional MTU (1500 | RFC 9946 |
| | bytes with an IP header) | |
+-------+-------------------------------+-----------+

表 7: Test Setup PDU Modifier Bitmap 注册表的初始值

12.3.4. Test Setup PDU Authentication Mode 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Setup PDU Authentication Mode" 注册表. Test Setup PDU 布局包含 authMode 字段. 此注册表中的代码点按照表 8 所述的注册程序 [RFC8126] 分配.

                +========+=========================+
| Range | Registration Procedures |
+========+=========================+
| 0-59 | IETF Review |
+--------+-------------------------+
| 60-63 | Experimental Use |
+--------+-------------------------+
| 64-255 | Reserved |
+--------+-------------------------+

表 8: Test Setup PDU Authentication Mode 注册表的注册程序

IANA 已在 "Test Setup PDU Authentication Mode" 注册表中分配以下十进制值:

+=======+===============================================+===========+
| Value | Description | Reference |
+=======+===============================================+===========+
| 0 | Not used | RFC 9946 |
+-------+-----------------------------------------------+-----------+
| 1 | Required authentication for | RFC 9946 |
| | the Control phase | |
+-------+-----------------------------------------------+-----------+
| 2 | Required authentication for | RFC 9946 |
| | the Control and Data phases | |
+-------+-----------------------------------------------+-----------+

表 9: Test Setup PDU Authentication Mode 注册表的初始值

12.3.5. Test Setup PDU Command Response Field 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Setup PDU Command Response Field" 注册表. Test Setup PDU 布局包含 cmdResponse 字段. 此注册表中的代码点按照表 10 所述的注册程序 [RFC8126] 分配.

                +=========+=========================+
| Range | Registration Procedures |
+=========+=========================+
| 0-127 | IETF Review |
+---------+-------------------------+
| 128-239 | Specification Required |
+---------+-------------------------+
| 240-249 | Experimental Use |
+---------+-------------------------+
| 250-254 | Private Use |
+---------+-------------------------+
| 255 | Reserved |
+---------+-------------------------+

表 10: Test Setup PDU Command Response Field 注册表的注册程序

IANA 已在 "Test Setup PDU Command Response Field" 注册表中分配以下十进制值:

+=========+============================================+===========+
| Value   | Description                                | Reference |
+=========+============================================+===========+
| 0       | None (used by client in Request)           | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 1       | Acknowledgment                             | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 2       | Bad protocol version                       | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 3       | Invalid Jumbo datagram option              | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 4       | Unexpected authentication in Setup Request | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 5       | Authentication missing in Setup Request    | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 6       | Invalid authentication method              | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 7       | Authentication failure                     | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 8       | Authentication time is invalid in Setup    | RFC 9946  |
|         | Request                                    |           |
+---------+--------------------------------------------+-----------+
| 9       | No maximum test bit rate specified         | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 10      | Server maximum bit rate exceeded           | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 11      | MTU option does not match server           | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 12      | Multi-connection parameters rejected by    | RFC 9946  |
|         | server                                     |           |
+---------+--------------------------------------------+-----------+
| 13      | Connection allocation failure on server    | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 240-249 | Reserved for Experimental Use              | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 250-254 | Reserved for Private Use                   | RFC 9946  |
+---------+--------------------------------------------+-----------+
| 255     | Reserved                                   | RFC 9946  |
+---------+--------------------------------------------+-----------+

表 11: Test Setup PDU Command Response Field 注册表的初始值

注意, 值 4 是为了与已经在使用的早期实验版本软件保持向后兼容而必需的. 此外, 值 6 表示客户端错误地使用了尚未标准化的 authMode, 即 authMode 大于 1 或 2.

12.3.6. Test Activation PDU Command Request 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Activation PDU Command Request" 注册表. Test Setup PDU 布局包含 cmdRequest 字段. 此注册表中的代码点按照表 12 所述的注册程序 [RFC8126] 分配.

                +=========+=========================+
| Range | Registration Procedures |
+=========+=========================+
| 0-127 | IETF Review |
+---------+-------------------------+
| 128-239 | Specification Required |
+---------+-------------------------+
| 240-249 | Experimental Use |
+---------+-------------------------+
| 250-254 | Private Use |
+---------+-------------------------+
| 255 | Reserved |
+---------+-------------------------+

表 12: Test Activation PDU Command Request 注册表的注册程序

IANA 已在 "Test Activation PDU Command Request" 注册表中分配以下十进制值:

       +=========+==============================+===========+
| Value | Description | Reference |
+=========+==============================+===========+
| 0 | No Request | RFC 9946 |
+---------+------------------------------+-----------+
| 1 | Request test in upstream | RFC 9946 |
| | direction (client to server) | |
+---------+------------------------------+-----------+
| 2 | Request test in downstream | RFC 9946 |
| | direction (server to client) | |
+---------+------------------------------+-----------+
| 240-249 | Reserved for Experimental | RFC 9946 |
| | Use | |
+---------+------------------------------+-----------+
| 250-254 | Reserved for Private Use | RFC 9946 |
+---------+------------------------------+-----------+
| 255 | Reserved | RFC 9946 |
+---------+------------------------------+-----------+

表 13: Test Activation PDU Command Request 注册表的初始值

12.3.7. Test Activation PDU Modifier Bitmap 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Activation PDU Modifier Bitmap" 注册表. Test Activation PDU 布局也包含 modifierBitmap 字段. 此注册表中的位图按照表 14 所述的注册程序 [RFC8126] 分配.

           +===================+=========================+
| Range | Registration Procedures |
+===================+=========================+
| 00000000-01111111 | IETF Review |
+-------------------+-------------------------+
| 10000000 | Reserved |
+-------------------+-------------------------+

表 14: Test Activation PDU Modifier Bitmap 注册表的注册程序

IANA 已在 "Test Activation PDU Modifier Bitmap" 注册表中分配以下位图值:

+=======+===============================================+===========+
| Value | Description | Reference |
+=======+===============================================+===========+
| 0x00 | No modifications | RFC 9946 |
+-------+-----------------------------------------------+-----------+
| 0x01 | Set when srIndexConf is | RFC 9946 |
| | start rate for search | |
+-------+-----------------------------------------------+-----------+
| 0x02 | Set for randomized UDP | RFC 9946 |
| | payload | |
+-------+-----------------------------------------------+-----------+

表 15: Test Activation PDU Modifier Bitmap 注册表的初始值

12.3.8. Test Activation PDU Rate Adjustment Algo 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Activation PDU Rate Adjustment Algo" 注册表. Test Activation PDU 布局包含 rateAdjAlgo 字段. 此注册表中的代码点按照表 16 所述的注册程序 [RFC8126] 分配.

                 +=======+=========================+
| Range | Registration Procedures |
+=======+=========================+
| A-Y | IETF Review |
+-------+-------------------------+
| Z | Reserved |
+-------+-------------------------+

表 16: Test Activation PDU Rate Adjustment Algo 注册表的注册程序

IANA 已在 "Test Activation PDU Rate Adjustment Algo" 注册表下添加以下说明:

|  Note: The algorithm identifier is a capitalized alphabetic UTF-8
| value (A-Z), specified by the corresponding incremental numeric.

IANA 已在 "Test Activation PDU Rate Adjustment Algo" 注册表中分配以下大写字母 UTF-8 值以及对应的递增数值:

      +================+=======================+==============+
| Value(Numeric) | Description | Reference |
+================+=======================+==============+
| A(n/a) | Not used | RFC 9946 |
+----------------+-----------------------+--------------+
| B(0) | Rate algorithm Type B | [Y.1540Amd2] |
+----------------+-----------------------+--------------+
| C(1) | Rate algorithm Type C | [TR-471] |
+----------------+-----------------------+--------------+

表 17: Test Activation PDU Rate Adjustment Algo 注册表的初始值

12.3.9. Test Activation PDU Command Response Field 注册表​

IANA 已在 "UDP Speed Test Protocol (UDPSTP)" 注册表组下创建 "Test Activation PDU Command Response Field" 注册表. Test Activation PDU 布局也包含 cmdResponse 字段. 此注册表中的代码点按照表 18 所述的注册程序 [RFC8126] 分配.

                +=========+=========================+
| Range | Registration Procedures |
+=========+=========================+
| 0-127 | IETF Review |
+---------+-------------------------+
| 128-239 | Specification Required |
+---------+-------------------------+
| 240-249 | Experimental Use |
+---------+-------------------------+
| 250-254 | Private Use |
+---------+-------------------------+
| 255 | Reserved |
+---------+-------------------------+

表 18: Test Activation PDU Command Response Field 注册表的注册程序

IANA 已在 "Test Activation PDU Command Response Field" 注册表中分配以下十进制值:

     +=========+==================================+===========+
| Value | Description | Reference |
+=========+==================================+===========+
| 0 | None (used by client in Request) | RFC 9946 |
+---------+----------------------------------+-----------+
| 1 | Server acknowledgment | RFC 9946 |
+---------+----------------------------------+-----------+
| 2 | Server indicates an error | RFC 9946 |
+---------+----------------------------------+-----------+
| 240-249 | Reserved for Experimental Use | RFC 9946 |
+---------+----------------------------------+-----------+
| 250-254 | Reserved for Private Use | RFC 9946 |
+---------+----------------------------------+-----------+
| 255 | Reserved | RFC 9946 |
+---------+----------------------------------+-----------+

表 19: Test Activation PDU Command Response Field 注册表的初始值

12.4. 指定专家指南​

建议为注册表变更请求任命多名指定专家.

指定专家应该应用的准则包括: 判断所提议的注册是否与现有条目重复, 以及注册说明是否清晰且符合此注册表的用途.

注册请求将在两周评审期内根据一名或多名指定专家的意见进行评估. 在评审期内, 指定专家将批准或拒绝注册请求, 并将此决定告知 IANA. 拒绝应包括解释, 并在适用时给出如何使请求成功的建议.