跳到主要内容

9. 相比 RFC Editor 模型版本 2 的变更 (Changes from Version 2 of the RFC Editor Model)

多年来, RFC 发布的流程和组织模型发生了显著变化. 最近的变化包括: 2009 年, [RFC5620] 定义了 RFC Editor 模型 (版本 1). 2012 年, [RFC6635] 定义了 RFC Editor 模型 (版本 2), 该模型随后在 2020 年由 [RFC8728] 作了小幅修改.

然而, 社区在版本 1 和版本 2 中遇到了若干问题, 包括缺少透明度, 社区参与策略定义的渠道不足, 以及权责边界不清晰.

为解决这些问题, IAB 于 2020 年成立了 RFC Editor Future Development Program, 用于围绕 RFC Editor 模型的进一步演进开展社区讨论和共识流程. 在该 Program 的主持下, 社区研究了若干变更. 这些变更旨在提高 RFC Series 整体策略定义的透明度和社区参与度, 同时确保 RFC Series 的连续性, 保持 RFC 的质量和及时发布, 确保文档可访问性, 并澄清权责边界.

[RFC9280] 是原 Program 内部讨论的结果. 它描述了 RFC Editor 模型版本 3, 并保持与 [RFC8729] 一致. 如前文所述, 本文档废弃 [RFC9280].

以下各节更详细地描述相对于版本 2 的变更.

9.1. RFC Editor 职能 (RFC Editor Function)​

若干此前分配给 RFC Editor, 更准确地说分配给 RFC Editor 职能的职责, 现在由 RSWG, RSAB, RPC, RSCE 和 IETF LLC 单独或组合履行. 这些职责包括战略领导的若干方面 ([RFC8728] 第 2.1.1 节), 代表 RFC Series ([RFC8728] 第 2.1.2 节), RFC 生产和发布的发展 ([RFC8728] 第 2.1.3 节), RFC Series 的发展 ([RFC8728] 第 2.1.4 节), 运营监督 ([RFC8729] 第 3.3 节), 策略监督 ([RFC8729] 第 3.4 节), 文档的编辑, 处理和发布 ([RFC8729] 第 4.2 节), 以及适用于 RFC Series 的指南和规则的制定与维护 ([RFC8729] 第 4.4 节). 除其他影响外, 这改变了 [RFC8730] 第 2.2 节中对 RFC Series Editor (RSE) 的依赖, 即关于"coordinating work and conforming to general RFC Series policies as specified by the IAB and RSE"的部分. 此外, 有关这些职责的若干细节已被修改, 以符合本文档定义的框架.

9.2. RFC Series Editor​

上一节概述的变更意味着, 作为个人或角色的 RFC Series Editor (RSE) 的职责, 相对于整体 RFC Editor 职能而言, 现在由 RSWG, RSAB, RSCE, RPC 和 IETF LLC 单独或组合拆分或共享. 更具体地说, RFC Editor 模型版本 3 下 RFC Series Consulting Editor (RSCE) 的职责, 在许多方面不同于 RFC Editor 模型版本 2 下 RFC Series Editor 的职责. 一般而言, 现有文档中对 RSE 的引用可以理解为指本文档所述的 RFC Editor 职能, 但不应理解为指 RSCE.

9.3. RFC Publisher​

实践中, RFC Production Center (RPC) 和 RFC Publisher 角色一直由同一实体履行, 并且预计这种做法会继续. 因此, 本文档取消这些角色之间的区分, 仅使用 RPC 这一称谓.

9.4. IAB​

在 RFC Editor 模型的早期版本中, IAB 负责监督 RFC Series, 并作为 RFC Series 相关最终冲突解决机构. IAB 在这些事项上的权力由 IAB Charter 描述 ([RFC2850], 并由 [RFC9283] 更新). 在 RFC Editor 模型版本 2 下, IAB 将部分权力委托给 RFC Series Oversight Committee (见第 9.5 节). 在 RFC Editor 模型版本 3 下, 策略定义权归属于 RSWG. RSWG 是社区成员开展工作的独立场所. 策略提案的批准由 RSAB 负责, RSAB 代表各个流并包括 RSCE. 而策略实施权归属于 IETF LLC.

9.5. RFC Series Oversight Committee (RSOC)​

实践中, IAB, RSOC 和 RSE 之间的关系以及权责边界被证明难以运作且有些不透明. 为克服其中一些问题, [RFC9280] 取消了 RSOC. [RFC8730] 等文档中对 RSOC 的引用均已过时.

9.6. RFC Series Advisory Group (RSAG)​

RFC Editor 模型版本 1 [RFC5620] 规定存在 RFC Series Advisory Group (RSAG), 而 RFC Editor 模型版本 2 不再规定该组织. 为避免疑义, [RFC9280] 确认 RSAG 已解散. RSAG 不应与本文档规定的 RFC Series Approval Board (RSAB) 混淆.

9.7. Editorial Stream​

除 [RFC8729] 已描述的各个流之外, 本文档还规定了 Editorial Stream.