跳到主要内容

13. IANA 考虑事项

本节注册 SIP Event 头字段参数 'shared', SIP Alert-Info 头字段参数 'appearance', 以及 SIP 对话包的 XML 命名空间扩展。

13.1. SIP Event 头字段参数: shared​

本文档在 [RFC3968] 定义的 "Header Field Parameters and Parameter Values" 注册表中, 为 Event 头字段定义 'shared' 头字段参数。

头字段 (Header Field)参数名 (Parameter Name)预定义值 (Predefined Values)参考 (Reference)
EventsharedNoRFC 7463

13.2. SIP Alert-Info 头字段参数: appearance​

本文档在 [RFC3968] 定义的 "Header Field Parameters and Parameter Values" 注册表中, 为 Alert-Info 头字段定义 'appearance' 参数。

头字段 (Header Field)参数名 (Parameter Name)预定义值 (Predefined Values)参考 (Reference)
Alert-InfoappearanceNoRFC 7463

13.3. URN 子命名空间注册: sa-dialog-info​

本节按照 [RFC3688] 中的流程注册一个新的 XML 命名空间。

URI: urn:ietf:params:xml:ns:sa-dialog-info.

注册人联系人 (Registrant Contact): IETF BLISS working group, <[email protected]>, Alan Johnston <[email protected]>

XML:

BEGIN
<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML Basic 1.0//EN"
"http://www.w3.org/TR/xhtml-basic/xhtml-basic10.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="content-type"
content="text/html;charset=iso-8859-1"/>
<title>Shared Appearance Dialog Information Namespace</title>
</head>
<body>
<h1>Namespace for Shared Appearance Dialog Information</h1>
<h2>urn:ietf:params:xml:ns:sa-dialog-info</h2>
<p>See <a href="http://www.rfc-editor.org/rfc/rfc7463.txt">
RFC 7463</a>.</p>
</body>
</html>
END

13.4. XML 模式注册​

本节按照 [RFC3688] 中的流程注册一个 XML 模式。

URI: urn:ietf:params:xml:schesa:sa-dialog-info.

注册人联系人 (Registrant Contact): IETF BLISS working group, <[email protected]>, Alan Johnston <[email protected]>

此模式的 XML 可在第 6 节找到。