1. 引言
互联网组管理协议(IGMP)[RFC1112, IGMPv2, IGMPv3] 允许 IPv4 主机将其 IP 组播组成员关系信息通告给相邻的路由器。IGMP 第 3 版(IGMPv3)[IGMPv3] 使主机能够选择性地请求或过滤来自组播组内各个源的流量。
组播侦听者发现协议(MLD)[RFC2710, MLDv2] 为 IPv6 主机提供了类似的功能。MLD 第 2 版(MLDv2)为 IPv6 提供了与 IGMPv3 类似的“源过滤”功能。
由于两者功能上的一致性,本文将使用“组管理协议”(Group Management Protocol,简称 GMP)这一术语来同时指代 IGMP 和 MLD;使用“源过滤 GMP”(Source Filtering GMP,简称 SFGMP)来共同指代 IGMPv3 和 MLDv2 这两种组管理协议。
通过在主机和路由器两侧对 SFGMP 协议进行少量修改,即可方便地使用特定源组播(SSM)。[SSM] 定义了实现 SSM 服务模型的系统所必须遵循的通用要求;本文档则定义了这些要求对实现 IGMPv3 和 MLDv2 的系统的具体适用方式。在此基础上,本文档定义了 IGMPv3 和 MLDv2 中用于 SSM 的主机部分和路由器部分的修改,并对这些协议在配合 SSM 地址使用时的行为作出了若干澄清。本文档更新了 IGMPv3 和 MLDv2 规范。
1.1. 术语
本文档中的关键词“必须”(MUST)、“绝不能”(MUST NOT)、“要求”(REQUIRED)、“应”(SHALL)、“不应”(SHALL NOT)、“应该”(SHOULD)、“不应该”(SHOULD NOT)、“推荐”(RECOMMENDED)、“可以”(MAY)和“可选”(OPTIONAL),均应按照 RFC 2119 [RFC2119] 中的描述进行解释。
为了强调本文档中对现有协议规范([RFC2710, MLDv2, IGMPv3])所作的“修改”而非仅仅“澄清”之处,任何协议修改都会以“MODIFICATION”标签加以标注。