跳到主要内容

6. IANA 考量 (IANA Considerations)

第 3 节中定义的 DS 字段取代 IPv4 头部 TOS 八位组 (以及 IPv6 流量类别八位组) 中之前的 IP 优先级/Precedence 字段使用方式.本备忘录将 RFC 791、RFC 1122、RFC 1349 和 RFC 1812 的相应部分标记为作废 (obsolete).IANA 管理 IPv4 TOS 八位组; 本备忘录所做更改相对于 RFC 791、RFC 1122、RFC 1349 和 RFC 1812 先前措辞的部分, 在本文发布时即成为作废.

DSCP 是 DS 字段的前 6 位 (位 0-5).DS 字段的最后两位 (位 6-7) 目前保留 (CU) 以备将来使用 ([ARCH] 和 [RFC791] 中曾将它们称为 MBZ).在关于 DS 字段这两个 CU 位的未来标准化工作中, IANA 仅按照 IESG 的批准执行操作.

DS 字段码点由 IANA 根据三个分配池进行分配.这些池在第 3 节中定义.

6.1 池 1: 标准操作 (Standards Action)​

该池包含 32 个码点.IANA 从池 1 为每个标准化 PHB (或一组 PHB) 分配一个码点.这些分配记录在 IANA 的"区分服务字段码点 (DSCP)"注册表中, 该注册表在 [RFC2474] 发布时创建.IANA 仅在 IESG 批准后 (即"标准操作") 才会向该注册表添加条目.

IANA 在该注册表中的第一个条目 (以及本备忘录中首次出现的标准化 PHB 组) 将是类选择器代码点 (Class Selector Codepoints), 其与之前在 IP 优先级/Precedence 字段中使用的八位组值保持兼容 (参见第 4 节), 如下表所示:


DSCP 值含义
0x00 (二进制 000000)类选择器 0 (CS0)
0x08 (二进制 001000)类选择器 1 (CS1)
0x10 (二进制 010000)类选择器 2 (CS2)
0x18 (二进制 011000)类选择器 3 (CS3)
0x20 (二进制 100000)类选择器 4 (CS4)
0x28 (二进制 101000)类选择器 5 (CS5)
0x30 (二进制 110000)类选择器 6 (CS6)
0x38 (二进制 111000)类选择器 7 (CS7)

6.2 池 2: 实验/本地使用 (EXP/LU)​

该池包含 16 个码点.其推荐使用由未来的标准文档确定.在本备忘录中, 它们被定义为实验或本地使用.必须 (MUST) 使用第 4 节中定义的类选择器兼容 PHB 来处理它们.必须 (MUST) 通过本地配置机制来分配它们, 而不是通过 IANA.

6.3 池 3: 实验/本地使用 (EXP/LU)​

该池包含 48 个码点.该空间目前未分配.建议 (RECOMMENDED) IANA 仅在 IESG 批准后分配该池中的码点.

建议 (RECOMMENDED) 从池 3 分配的码点取值必须 (MUST) 不是 11x000 (即 x 取 0 或 1), 因为该空间为类选择器兼容 PHB 预留, 并且为避免与池 2 混淆.建议 (RECOMMENDED) 在实验或部署期间使用池 3 中的码点, 以测试不属于类选择器兼容 PHB 的逐跳行为.建议 (RECOMMENDED) 仅当建议 (RECOMMENDED) 的码点已永久分配 (通过"标准操作") 时, 才进行永久部署.使用池 3 中的码点进行的部署应该 (SHOULD) 被记录在 RFC 中, 以便先前的实验性使用不会阻碍未来的标准化.必须 (MUST) 由 IANA 维护一个注册表来跟踪此类先前使用.


注意: 池 1 和池 2 中的码点已在 [RFC2474] 中分配.