Skip to main content

RFC 9931 - Security Considerations for Optimistic Protocol Transitions in HTTP/1.1

  • Status: Proposed Standard
  • Published: March 2026
  • Stream: IETF
  • Updates: RFC 9112, RFC 9298
  • Errata: No Errata

Abstract​

RFC 9931 describes security considerations for data sent optimistically before an HTTP/1.1 protocol transition is confirmed. It updates RFC 9112 and RFC 9298 with requirements intended to avoid request smuggling and related security issues.

Contents​