Skip to main content

RFC 8446 - The Transport Layer Security (TLS) Protocol Version 1.3

  • Status: Proposed Standard
  • Published: August 2018
  • Stream: IETF
  • Updates: RFC5705, RFC6066
  • Obsoletes: RFC5077, RFC5246, RFC6961
  • Errata: No Errata

Abstract​

This document specifies version 1.3 of the Transport Layer Security (TLS) protocol. TLS allows client/server applications to communicate over the Internet in a way that is designed to prevent eavesdropping, tampering, and message forgery.

This document updates RFCs 5705 and 6066 and obsoletes RFCs 5077, 5246, and 6961. This document also specifies new requirements for TLS 1.2 implementations.


Contents​

Appendices​