Skip to main content

RFC 7516 - JSON Web Encryption (JWE)

  • Status: Proposed Standard
  • Published: May 2015
  • Stream: IETF
  • Errata: No Errata

Abstract​

JSON Web Encryption (JWE) represents encrypted content using JSON-based data structures. The JWE cryptographic mechanisms encrypt and provide integrity protection for an arbitrary sequence of octets.


Table of Contents​

Appendices​


JOSE Family RFCs​

  • RFC 7515 - JSON Web Signature (JWS)
  • RFC 7516 - JSON Web Encryption (JWE) ← This document
  • RFC 7517 - JSON Web Key (JWK)
  • RFC 7518 - JSON Web Algorithms (JWA)
  • RFC 7519 - JSON Web Token (JWT)