Skip to main content

21. IANA Considerations

This specification registers new SDP attributes, four new STUN attributes, and one new STUN error response.

21.1. SDP Attributes​

This specification defines seven new SDP attributes per the procedures of Section 8.2.4 of [RFC4566]. The required information for the registrations is included here.

21.1.1. candidate Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: candidate
  • Long Form: candidate
  • Type of Attribute: media-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and provides one of many possible candidate addresses for communication. These addresses are validated with an end-to-end connectivity check using Session Traversal Utilities for NAT (STUN)).
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.2. remote-candidates Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: remote-candidates
  • Long Form: remote-candidates
  • Type of Attribute: media-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and provides the identity of the remote candidates that the offerer wishes the answerer to use in its answer.
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.3. ice-lite Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: ice-lite
  • Long Form: ice-lite
  • Type of Attribute: session-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and indicates that an agent has the minimum functionality required to support ICE inter-operation with a peer that has a full implementation.
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.4. ice-mismatch Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: ice-mismatch
  • Long Form: ice-mismatch
  • Type of Attribute: session-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and indicates that an agent is ICE capable, but did not proceed with ICE due to a mismatch of candidates with the default destination for media signaled in the SDP.
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.5. ice-pwd Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: ice-pwd
  • Long Form: ice-pwd
  • Type of Attribute: session- or media-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and provides the password used to protect STUN connectivity checks.
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.6. ice-ufrag Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: ice-ufrag
  • Long Form: ice-ufrag
  • Type of Attribute: session- or media-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and provides the fragments used to construct the username in STUN connectivity checks.
  • Appropriate Values: See Section 15 of RFC 5245.

21.1.7. ice-options Attribute​

  • Contact Name: Jonathan Rosenberg, [email protected].
  • Attribute Name: ice-options
  • Long Form: ice-options
  • Type of Attribute: session-level
  • Charset Considerations: The attribute is not subject to the charset attribute.
  • Purpose: This attribute is used with Interactive Connectivity Establishment (ICE), and indicates the ICE options or extensions used by the agent.
  • Appropriate Values: See Section 15 of RFC 5245.

21.2. STUN Attributes​

This section registers four new STUN attributes per the procedures in [RFC5389].

  • 0x0024 PRIORITY
  • 0x0025 USE-CANDIDATE
  • 0x8029 ICE-CONTROLLED
  • 0x802A ICE-CONTROLLING

21.3. STUN Error Responses​

This section registers one new STUN error response code per the procedures in [RFC5389].

  • 487 Role Conflict: The client asserted an ICE role (controlling or controlled) that is in conflict with the role of the server.