Skip to main content

3. MIME Type Registration of text/csv

This section provides the media type registration application, according to RFC 2048 [1].

Registration Information​

To: [email protected]

Subject: Registration of MIME media type text/csv

MIME Media Type Name​

text

MIME Subtype Name​

csv

Required Parameters​

None

Optional Parameters​

charset Parameter​

Common usage of CSV is US-ASCII, but other character sets defined by IANA for the "text" tree may be used with the "charset" parameter.

header Parameter​

The "header" parameter indicates the presence or absence of a header line. Valid values are "present" or "absent". Implementers choosing not to use this parameter must make their own decisions as to whether the header line is present or absent.

Encoding Considerations​

As specified in Section 4.1.1 of RFC 2046 [3], this media type uses CRLF to denote line breaks. However, implementers should note that some implementations may use other values.

Security Considerations​

CSV files contain passive text data and should not pose any risks. However, malicious binary data could theoretically be included to exploit potential buffer overruns in programs that process CSV data. In addition, private data may be shared via this format, as is true for any text data.

Interoperability Considerations​

Because there is no single specification, considerable differences exist among implementations. Implementers processing CSV files should follow the RFC 793 [8] principle: "be conservative in what you do, be liberal in what you accept from others." A tentative common definition can be found in Section 2.

Implementations deciding not to use the optional "header" parameter must make their own decisions as to whether the header is absent or present.

Published Specification​

Although numerous private specifications exist for various programs and systems, there is no single "master" specification for this format. A tentative common definition can be found in Section 2.

Applications That Use This Media Type​

  • Spreadsheet programs
  • Various data conversion tools

Additional Information​

Magic Number(s)​

None

File Extension(s)​

CSV

Macintosh File Type Code(s)​

TEXT

Contact Information​

Person and email address to contact for further information: Yakov Shafranovich [email protected]

Intended usage: COMMON

Author/Change controller: IESG