メインコンテンツまでスキップ

6. IANA Considerations

この節では unsigned X.509 certificates の RFC テキストを保持し, id-alg-unsigned, id-rdna-unsigned, zero-length signatureValue, issuer handling, extension guidance, validation rules, IANA registrations, ASN.1 module を扱う.

RFC 原文​

6.  IANA Considerations

6.1.  Module Identifier

   IANA has added the following entry in the "SMI Security for PKIX
   Module Identifier" registry, defined by [RFC7299]:

             +=========+=========================+===========+
             | Decimal | Description             | Reference |
             +=========+=========================+===========+
             | 122     | id-mod-algUnsigned-2025 | RFC 9925  |
             +---------+-------------------------+-----------+

                                  Table 1

6.2.  Algorithm

   IANA has added the following entry to the "SMI Security for PKIX
   Algorithms" registry [RFC7299]:

                 +=========+=================+===========+
                 | Decimal | Description     | Reference |
                 +=========+=================+===========+
                 | 36      | id-alg-unsigned | RFC 9925  |
                 +---------+-----------------+-----------+

                                  Table 2

6.3.  Relative Distinguished Name Attribute

   To allocate id-rdna-unsigned, this document introduces a new PKIX OID
   arc for relative distinguished name attributes:

   IANA has added the following entry to the "SMI Security for PKIX"
   registry [RFC7299]:

      +=========+=======================================+===========+
      | Decimal | Description                           | Reference |
      +=========+=======================================+===========+
      | 25      | Relative Distinguished Name Attribute | RFC 9925  |
      +---------+---------------------------------------+-----------+

                                  Table 3

   IANA has created the "SMI Security for PKIX Relative Distinguished
   Name Attribute" registry within the "Structure of Management
   Information (SMI) Numbers (MIB Module Registrations)" registry group.

   The new registry's description is
   "iso.org.dod.internet.security.mechanisms.pkix.rdna
   (1.3.6.1.5.5.7.25)".

   The new registry has three columns and is initialized with the
   following values:

                +=========+==================+===========+
                | Decimal | Description      | Reference |
                +=========+==================+===========+
                | 1       | id-rdna-unsigned | RFC 9925  |
                +---------+------------------+-----------+

                                 Table 4

   Future updates to this table are to be made according to the
   Specification Required policy as defined in [RFC8126].