メインコンテンツまでスキップ

10. IANA Considerations (IANA考慮事項)

10.1. BGP CAR SAFIs​

IANAは, "後続アドレスファミリ識別子 (SAFI) パラメータ" 登録グループ内の "SAFI値" レジストリからSAFI値83 (BGP CAR) とSAFI値84 (BGP VPN CAR) を割り当てました。本文書が参照として使用されます。

10.2. "BGP CAR NLRI Types" Registry (BGP CAR NLRIタイプレジストリ)​

IANAは, "ボーダーゲートウェイプロトコル (BGP) パラメータ" 登録グループ内に "BGP CAR NLRIタイプ" レジストリを作成しました。本文書が参照として使用されます。このレジストリは, BGP CAR NLRIタイプの1オクテットコードポイントを割り当てるために使用されます:

TypeNLRI TypeReference
0Reserved (予約済み)RFC 9871
1Color-Aware Route (カラーアウェアルート)RFC 9871
2IP Prefix (IPプレフィックス)RFC 9871
3-255Unassigned (未割り当て)-

レジストリ内の割り当ては, [RFC8126]で指定されている "仕様が必要" ポリシーに従う必要があります。

10.3. "BGP CAR NLRI TLV" Registry (BGP CAR NLRI TLVレジストリ)​

IANAは, "ボーダーゲートウェイプロトコル (BGP) パラメータ" 登録グループ内に "BGP CAR NLRI TLVタイプ" レジストリを作成しました。本文書が参照として使用されます。このレジストリは, BGP CAR NLRI非キーTLVタイプの6ビットコードポイントを割り当てるために使用されます:

TypeNLRI TLV TypeReference
0Reserved (予約済み)RFC 9871
1Label (ラベル)RFC 9871
2Label-Index (ラベルインデックス)RFC 9871
3SRv6 SIDRFC 9871
4-64Unassigned (未割り当て)-

10.4. Guidance for Designated Experts (指定専門家へのガイダンス)​

指定専門家 (DE) は, 仕様が "仕様が必要" ポリシーの要件を満たしていることを確認する必要があります。DEは, コードポイント要求がIETF内でレビューとコメントのために利用可能にされていることを検証し, IETF内のアクティブまたは公開された作業と競合しないことを確保しなければなりません。

10.4.1. "BGP CAR NLRI Types" Registryの追加評価基準​

  • 新しいNLRIタイプと本文書でBGP CAR SAFIに指定された現在のNLRIタイプ間の相互運用性を確認
  • 設計の完全性と一貫性を検証

10.4.2. "BGP CAR NLRI TLV" Registryの追加評価基準​

  • 新しいTLVタイプと既存のTLVタイプの相互運用性を確認
  • TLV設計の明確性と一貫性を検証

10.5. "Border Gateway Protocol (BGP) Extended Communities" Registry​

IANAは, "BGP拡張コミュニティ" レジストリの "推移的不透明拡張コミュニティサブタイプ" レジストリにサブタイプ値0x1bを割り当てました。名前は "Local Color Mapping" で, 本文書を参照します。


11. Manageability and Operational Considerations (管理性と運用上の考慮事項)

運用上の考慮事項​

カラー計画:

  • オペレーターはカラー割り当て戦略を慎重に計画すべきです
  • 組織内で一貫したカラーとインテントのマッピングを維持
  • カラードメイン境界で適切なカラー再マッピングを実行

ルーティングポリシー:

  • CARルートの通知と受け入れを制御するための適切なルーティングポリシーを設定
  • 不要なルート伝播を制限するためのフィルタリングメカニズムを使用
  • スケーラビリティを最適化するためにオンデマンドルートサブスクリプションを実装

監視とデバッグ:

  • CARルートの伝播と解決を監視
  • カラーアウェアパスが期待通りに確立されていることを確認
  • サービストラフィックステアリングを追跡するための適切なツールを使用

相互運用性:

  • 異なるベンダーデバイス間の相互運用性を確保
  • 新機能を展開する前に徹底的なテストを実施
  • ピアリングドメインとカラーマッピングを調整

展開戦略:

  • 段階的な展開アプローチを採用
  • コアネットワークから開始し, 徐々にエッジに拡大
  • スケーラビリティを向上させるために階層設計を活用

12. Security Considerations (セキュリティ考慮事項)

BGP CARは, [RFC4271]で説明されているBGPプロトコルのすべてのセキュリティ考慮事項を継承します。

主要なセキュリティ考慮事項​

ルーティングセキュリティ:

  • BGP CARルートは信頼されたドメイン内で交換されるべきです
  • 適切なBGPセッション保護メカニズム (例: TCP MD5, BGP-SEC) を使用
  • 不正なルート注入を防ぐために厳格なルーティングポリシーを実装

カラー操作:

  • 誤って設定されたカラーマッピングは最適でないパス選択につながる可能性があります
  • 悪意のあるノードがトラフィックエンジニアリングに影響を与えるためにカラー値を操作しようとする可能性があります
  • ルーティングポリシーを使用してカラー値を検証およびフィルタリング

データプレーンセキュリティ:

  • カプセル化メカニズム (MPLS, SR, SRv6) のセキュリティを確保
  • ラベルスプーフィングとSID操作を防止
  • 必要に応じて暗号化トランスポートを使用

DoS保護:

  • BGP更新フラッディングを防ぐためにレート制限を実装
  • 異常なルートチャーンを監視
  • BGP ADD-PATHを使用する際はスケーラビリティへの影響に注意

プライバシー考慮事項:

  • カラーとインテント情報はネットワークトポロジとポリシーを明らかにする可能性があります
  • 組織境界を越えた情報共有を慎重に検討
  • ルーティング情報の可視性を制限するために適切なアクセス制御を使用

13. References (参考文献)

13.1. Normative References (規範的参考文献)​

本文書は以下のRFCを規範的に参照します:

  • [RFC2119]: Key words for use in RFCs to Indicate Requirement Levels
  • [RFC4271]: A Border Gateway Protocol 4 (BGP-4)
  • [RFC4360]: BGP Extended Communities Attribute
  • [RFC4760]: Multiprotocol Extensions for BGP-4
  • [RFC7311]: The Accumulated IGP Metric Attribute for BGP
  • [RFC7606]: Revised Error Handling for BGP UPDATE Messages
  • [RFC8174]: Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words
  • [RFC8277]: Using BGP to Bind MPLS Labels to Address Prefixes
  • [RFC8402]: Segment Routing Architecture
  • [RFC8669]: Segment Routing Prefix Segment Identifier Extensions for BGP
  • [RFC9012]: The BGP Tunnel Encapsulation Attribute
  • [RFC9252]: BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)
  • [RFC9256]: Segment Routing Policy Architecture
  • [RFC8126]: Guidelines for Writing an IANA Considerations Section in RFCs

13.2. Informative References (情報的参考文献)​

本文書は以下の文書を情報的に参照します:

  • [INTENT-AWARE]: Intent-Aware Transport Problem Statement and Requirements
  • [RFC2545]: Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing
  • [RFC4684]: Constrained Route Distribution for Border Gateway Protocol/MultiProtocol Label Switching (BGP/MPLS) Internet Protocol (IP) Virtual Private Networks (VPNs)
  • [RFC7911]: Advertisement of Multiple Paths in BGP
  • [RFC8986]: Segment Routing over IPv6 (SRv6) Network Programming
  • [RFC9350]: IGP Flexible Algorithm
  • [SRv6-INTERWORK]: SRv6 and MPLS Interworking

(その他の参考文献については, RFC 9871の原文を参照してください)


注: 完全な参考文献リストと詳細なセキュリティ分析については, RFC 9871の原文を参照してください。