メインコンテンツまでスキップ

RFC 9562 - 汎用一意識別子 (UUID)

  • ステータス: Proposed Standard
  • 発行日: May 2024
  • ストリーム: IETF
  • 廃止: RFC4122
  • エラッタ: エラッタなし

概要​

本仕様は UUID (Universally Unique IDentifiers, 汎用一意識別子), GUID (Globally Unique IDentifiers, グローバル一意識別子) とも呼ばれるもの, および UUID の統一リソース名前空間を定義します。UUID は 128 ビット長で, 空間と時間にわたる一意性を保証することを目的としています。UUID は, 最初に Apollo Network Computing System (NCS) で使用され, その後 Open Software Foundation (OSF) の Distributed Computing Environment (DCE) で使用され, その後 Microsoft Windows プラットフォームで使用されました。

本仕様は, OSF (現在は "The Open Group" として知られています) の許可を得て OSF DCE 仕様から派生しています。OSF DCE 仕様の以前のバージョンからの情報が本文書に組み込まれています。本文書は RFC 4122 を廃止します。


本文書の位置付け​

これはインターネット標準化過程文書です。

本文書はインターネット技術タスクフォース (IETF) の成果物です。これは IETF コミュニティの合意を表しています。公開レビューを受け, インターネット技術運営委員会 (IESG) によって公開が承認されました。インターネット標準に関する詳細情報は, RFC 7841 のセクション 2 で入手できます。

本文書の現在の状態, 正誤表, およびフィードバックの提供方法に関する情報は, https://www.rfc-editor.org/info/rfc9562 で入手できます。


著作権表示​

著作権 (c) 2024 IETF Trust および文書著者として特定された人物。全著作権所有。

本文書は BCP 78 および本文書の発行日に有効な IETF 文書に関する IETF Trust の法的規定 (https://trustee.ietf.org/license-info) の対象となります。これらの文書は, 本文書に関するあなたの権利と制限を説明しているため, 注意深く確認してください。本文書から抽出されたコードコンポーネントには, Trust 法的規定のセクション 4.e に記載されている Revised BSD License テキストを含める必要があり, Revised BSD License に記載されているように保証なしで提供されます。


目次​


謝辞​

著者は, 貴重なフィードバックをいただいたすべての貢献者とレビュアーに感謝します。


著者の連絡先​

Kyzer R. Davis
Cisco Systems
Email: <[email protected]>

Brad G. Peabody
Uncloud
Email: <[email protected]>

Paul J. Leach
ワシントン大学
Email: <[email protected]>


関連リソース​