メインコンテンツまでスキップ

RFC 7517 - JSON Web Key (JWK)

  • ステータス: Proposed Standard
  • 発行日: May 2015
  • ストリーム: IETF
  • エラッタ: エラッタなし

概要 (Abstract)​

JSON Web Key (JWK) は、暗号鍵 (Cryptographic Key) を表現するための JavaScript Object Notation (JSON) データ構造です。本仕様は、JWK のセットを表現する JWK Set JSON データ構造も定義します。本仕様で使用される暗号アルゴリズムと識別子は、別途の JSON Web Algorithms (JWA) 仕様およびその仕様によって確立された IANA レジストリで説明されています。


目次 (Table of Contents)​

付録 (Appendices)​


関連リソース​

JOSE シリーズ RFC​

  • RFC 7515 - JSON Web Signature (JWS)
  • RFC 7516 - JSON Web Encryption (JWE)
  • RFC 7517 - JSON Web Key (JWK) ← 本文書
  • RFC 7518 - JSON Web Algorithms (JWA)
  • RFC 7519 - JSON Web Token (JWT)