メインコンテンツまでスキップ

RFC 7022

  • ステータス: Proposed Standard
  • 発行日: September 2013
  • ストリーム: IETF
  • 更新: RFC3550
  • 廃止: RFC6222
  • エラッタ: エラッタなし

RTP 制御プロトコル (RTCP) 正準名 (CNAME) 選択のためのガイドライン​

RFC7022
タイトルRTP 制御プロトコル (RTCP) 正準名 (CNAME) 選択のためのガイドライン
発行日2013年9月
ステータス標準トラック
著者A. Begen, C. Perkins, D. Wing, E. Rescorla
旧版6222
更新3550

概要​

RTP 制御プロトコル (RTCP) 正準名 (CNAME) は、RTP エンドポイントの永続的なトランスポートレベルの識別子です。RTP エンドポイントの同期ソース (SSRC) 識別子は、衝突が検出された場合や RTP アプリケーションが再起動された場合に変更される可能性がありますが、その RTCP CNAME は変更されないことが意図されています。これにより、RTP エンドポイントを一意に識別し、それらの RTP メディアストリームと関連付けることができます。

適切に機能させるためには、RTCP CNAME は RTP セッションの参加者間で一意である必要があります。しかし、RTP 標準 (RFC 3550) で提供されている RTCP CNAME を選択するための既存のガイドラインは、この一意性を実現するには不十分です。エンドポイントが一意の RTCP CNAME を選択できるようにガイドラインを更新するために RFC 6222 が公開されました。残念ながら、その後の調査により、新しいアルゴリズムの一部が不必要に複雑であったり、効果が低かったりすることが判明しました。本文書はこれらの懸念に対処し、RFC 6222 を置き換えるものです。

目次​