メインコンテンツまでスキップ

RFC 5944 - IPv4のIPモビリティサポート(改訂版)

  • ステータス: Proposed Standard
  • 発行日: November 2010
  • ストリーム: IETF
  • 廃止: RFC3344
  • エラッタ: エラッタなし

概要 (Abstract)​

本文書は、インターネット内のモバイルノード (Mobile Node) へのIPデータグラムの透過的なルーティングを可能にするプロトコル拡張を規定します。各モバイルノードは、インターネットへの現在の接続ポイントに関係なく、常にそのホームアドレス (Home Address) によって識別されます。ホームから離れた場所にいる場合、モバイルノードは気付アドレス (Care-of Address) にも関連付けられ、これはインターネットへの現在の接続ポイントに関する情報を提供します。プロトコルは、ホームエージェント (Home Agent) に気付アドレスを登録する機能を提供します。ホームエージェントは、モバイルノード宛のデータグラムをトンネル経由で気付アドレスに送信します。トンネルの終端に到着した後、各データグラムはモバイルノードに配信されます。


目次 (Contents)​

  • 1. Introduction (序論)

    • 1.1 プロトコル要件
    • 1.2 目標
    • 1.3 前提条件
    • 1.4 適用性
    • 1.5 新しいアーキテクチャエンティティ
    • 1.6 用語
    • 1.7 プロトコル概要
    • 1.8 メッセージフォーマットとプロトコル拡張性
    • 1.9 Type-Length-Value拡張フォーマット
    • 1.10 ロング拡張フォーマット
    • 1.11 ショート拡張フォーマット
  • 2. Agent Discovery (エージェント検出)

    • 2.1 エージェント広告
    • 2.2 エージェント要請
    • 2.3 外部エージェントとホームエージェントの考慮事項
    • 2.4 モバイルノードの考慮事項
  • 3. Registration (登録)

    • 3.1 登録概要
    • 3.2 認証
    • 3.3 登録要求
    • 3.4 登録応答
    • 3.5 登録拡張
    • 3.6 モバイルノードの考慮事項
    • 3.7 外部エージェントの考慮事項
    • 3.8 ホームエージェントの考慮事項
  • 4. Routing Considerations (ルーティングの考慮事項)

    • 4.1 カプセル化タイプ
    • 4.2 ユニキャストデータグラムルーティング
    • 4.3 ブロードキャストデータグラム
    • 4.4 マルチキャストデータグラムルーティング
    • 4.5 モバイルルーター
    • 4.6 ARP、プロキシARP、グレーシャスARP
  • 5. Security Considerations (セキュリティの考慮事項)

    • 5.1 メッセージ認証コード
    • 5.2 セキュリティ懸念の領域
    • 5.3 鍵管理
    • 5.4 良好な乱数の選択
    • 5.5 プライバシー
    • 5.6 イングレスフィルタリング
    • 5.7 リプレイ保護
  • 6. IANA Considerations (IANAの考慮事項)

    • 6.1 モバイルIPメッセージタイプ
    • 6.2 RFC 1256への拡張
    • 6.3 登録メッセージへの拡張
    • 6.4 登録応答のコード値
  • 7. Acknowledgments (謝辞)

  • 8. References (参考文献)

    • 8.1 規範的参考文献
    • 8.2 参考情報

附属書 (Appendices)​


関連リソース​

  • 公式原文: https://www.rfc-editor.org/rfc/rfc5944.txt
  • 公式ページ: https://datatracker.ietf.org/doc/html/rfc5944
  • 正誤表: https://www.rfc-editor.org/errata_search.php?rfc=5944


1. はじめに (Introduction)​

IP バージョン 4 は、ノードの IP アドレスがそのノードのインターネットへの接続点を一意に識別することを前提としています。したがって、ノードはその IP アドレスが示すネットワーク上に存在しなければ、宛先となるデータグラムを受信できません。ノードが通信能力を失わずに接続点を変更できるようにするには、通常以下の 2 つのメカニズムのいずれかを採用しなければなりません。

  • ノードは接続点を変更するたびに IP アドレスを変更しなければならない、または
  • ホスト固有のルートをインターネットルーティング構造の大部分に伝播しなければならない

これらの代替案はどちらも一般的に受け入れられません。最初の代替案は、ノードが位置を変更する際にトランスポート層以上の接続を維持できなくなります。2 番目の代替案には、特にノート(モバイル)コンピューターの販売の爆発的な増加を考慮すると、明らかで深刻なスケーラビリティの問題があります。

インターネット内でノードのモビリティに対応するための新しいスケーラブルなメカニズムが必要です。本文書は、ノードが IP アドレスを変更せずにインターネットへの接続点を変更できるようにするメカニズムを定義します。

1.1. プロトコル要件 (Protocol Requirements)​

モバイルノード (Mobile Node) は、インターネットへのリンク層接続点を変更した後も、IP アドレスを変更せずに他のノードと通信できなければなりません。

モバイルノードは、これらのモビリティ機能を実装していない他のノードと通信できなければなりません。

すべての位置更新メッセージは、リモートリダイレクト攻撃を防ぐために認証 (Authentication) されなければなりません。

1.2. 目標 (Goals)​

モバイルノードがインターネットに直接接続するリンクは通常無線リンクである可能性があります。したがって、そのリンクの帯域幅は従来の有線ネットワークよりはるかに低く、エラー率も高い場合があります。また、モバイルノードはバッテリー駆動である可能性が高く、消費電力の最小化が重要です。

1.3. 前提条件 (Assumptions)​

本文書で定義されるプロトコルは IP アドレスの割り当てに追加の制約を課しません。

本プロトコルは、モバイルノードが通常 1 秒に 1 回を超える頻度でインターネットへの接続点を変更しないことを前提としています。

1.4. 適用性 (Applicability)​

Mobile IP は、ノードが 1 つの IP サブネットから別の IP サブネットに移動できるように設計されています。同種メディア間のモビリティと異種メディア間のモビリティの両方に適用できます。

1.5. 新しいアーキテクチャエンティティ (New Architectural Entities)​

Mobile IP は以下の新しい機能エンティティを導入します。

モバイルノード (Mobile Node)

あるネットワークまたはサブネットから別のネットワークまたはサブネットへ接続点を変更するホストまたはルーター。モバイルノードは IP アドレスを変更せずに位置を変更できます。

ホームエージェント (Home Agent)

モバイルノードのホームネットワーク上のルーター。モバイルノードが離れている場合、トンネル (Tunnel) を通じてデータグラムをモバイルノードに転送し、モバイルノードの現在の位置情報を維持します。

フォーリンエージェント (Foreign Agent)

モバイルノードが訪問するネットワーク上のルーター。登録時にモバイルノードにルーティングサービスを提供します。

モバイルノードはホームネットワーク上で長期的な IP アドレスを割り当てられます。このホームアドレス (Home Address) は静的ホストに「永続的な」IP アドレスを提供するのと同じ方法で管理されます。ホームネットワークから離れている場合、気付アドレス (Care-of Address) がモバイルノードに関連付けられ、モバイルノードの現在の接続点を反映します。

1.6. 用語 (Terminology)​

本文書のキーワード「MUST」「MUST NOT」「REQUIRED」「SHALL」「SHALL NOT」「SHOULD」「SHOULD NOT」「RECOMMENDED」「MAY」「OPTIONAL」は RFC 2119 [1] の記述に従って解釈されます。

気付アドレス (Care-of Address)

モバイルノードが離れている場合に、モバイルノードへの転送のためのトンネルエンドポイント。

対応ノード (Correspondent Node)

モバイルノードと通信するピアノード。

ホームアドレス (Home Address)

モバイルノードに割り当てられ長期的に使用される IP アドレス。ノードのインターネットへの接続点に関わらず変わりません。

ホームネットワーク (Home Network)

モバイルノードのホームアドレスに一致するネットワークプレフィックスを持つネットワーク。

モビリティバインディング (Mobility Binding)

ホームアドレスと気付アドレスの関連付け、およびその関連付けの残余生存時間 (Lifetime)。

トンネル (Tunnel)

データグラムがカプセル化されて辿るパス。

1.7. プロトコル概要 (Protocol Overview)​

Mobile IP には以下のサポートサービスが定義されています。

エージェント発見 (Agent Discovery)

ホームエージェントとフォーリンエージェントは、サービスを提供する各リンクで可用性を広告できます。

登録 (Registration)

モバイルノードがホームから離れている場合、気付アドレスをホームエージェントに登録します。

以下のステップが Mobile IP プロトコル操作の概要を提供します。

  • モバイルエージェントはエージェント広告メッセージ (Agent Advertisement Messages) を通じて存在を広告します。
  • モバイルノードはこれらのエージェント広告を受信し、ホームネットワーク上にいるか外部ネットワーク上にいるかを判断します。
  • モバイルノードがホームネットワーク上にいることを検出した場合、モビリティサービスなしで動作します。
  • モバイルノードが外部ネットワークに移動したことを検出した場合、外部ネットワーク上で気付アドレスを取得します。
  • 離れて動作するモバイルノードは、新しい気付アドレスをホームエージェントに登録します。
  • モバイルノードのホームアドレス宛てのデータグラムはホームネットワークに配信されます。
  • ホームネットワーク上で、ホームエージェントはこれらのデータグラムをインターセプトし、モバイルノードの気付アドレスにトンネリングします。
  • 気付アドレスで、データグラムはデカプセル化されてモバイルノードに配信されます。

1.8. メッセージフォーマットとプロトコル拡張性 (Message Format and Protocol Extensibility)​

Mobile IP は UDP と ICMP を使用して転送される多くの新しい制御メッセージを定義します。

1.9. Mobile IP 拡張の TLV 拡張フォーマット (Type-Length-Value Extension Format for Mobile IP Extensions)​

本仕様は Mobile IP メッセージに含まれる拡張を TLV (Type-Length-Value) フォーマットとして定義します。

1.10. 長拡張フォーマット (Long Extension Format)​

長拡張フォーマットはタイプ値が 128 未満の拡張に使用されます。16 ビットの長さフィールドを使用し、最大 65,535 バイトのデータを含む拡張を許可します。

 0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Type | Subtype | Length |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Value (variable) |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

1.11. 短拡張フォーマット (Short Extension Format)​

短拡張フォーマットはタイプ値が 128 以上の拡張に使用されます。8 ビットの長さフィールドを使用し、最大 255 バイトのデータを含む拡張を許可します。

 0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Type | Length | Value (variable) |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+