メインコンテンツまでスキップ

3. 解決策としてのクラスレスアドレッシング (Classless Addressing as a Solution)

コミュニティが作成した解決策は、クラスA/B/Cネットワークアドレス割り当てシステムを廃止し、代わりに「クラスレス」の階層的なIPアドレスブロック (プレフィックス (Prefix) と呼ばれる) を使用することでした。プレフィックスの割り当ては、グローバルルーティングシステムのスケーリングを容易にするために集約が使用できるように、基礎となるインターネットトポロジーにおおよそ従うことを意図しています。この戦略の1つの意味は、プレフィックスの割り当てと集約は一般にプロバイダ-サブスクライバー関係に従って行われることです。これは、インターネットトポロジーがどのように決定されるかによるものです。

[RFC1338] および [RFC1519] で最初に提案されたとき、このアドレッシング計画は比較的短期的な対応として意図されており、約3年から5年間続くものとされ、その間により恒久的なアドレッシングおよびルーティングアーキテクチャが設計および実装されることになっていました。元の文書の日付から推測できるように、CIDRはその予想寿命をはるかに超え、上記の問題に対する中期的な解決策となっています。

以下のテキストでは、ここで議論されている割り当てアーキテクチャを実装するために実施された現在のポリシーと手順について説明します。この説明は、IANAへの指示として解釈されることを意図したものではありません。

地域インターネットレジストリ (Regional Internet Registries) によって実装されたアドレス管理戦略と組み合わせて (詳細は [NRO] を参照)、CIDRスタイルのアドレッシングの展開は、IPv4アドレス空間が消費される速度を低減し、上記の問題#3に対する短期から中期的な救済を提供しています。

定義されているように、この計画は、集約に適さないレガシー「クラスC」空間の部分 (「スワンプ (Swamp)」と呼ばれることもあります) の再割り当てを必要とせず、想定してもいません。これを行うことで、ルーティングテーブルのサイズをある程度削減できます (現在の推定では、「スワンプ」には約15,000のエントリが含まれています) が、大幅な再番号付けコストがかかります。同様に、トランジットサービスプロバイダーを変更する際にエンドサイトが再番号付けを行うという厳格な要件はありませんが、エンドサイトは、グローバルルーティングシステムへのプレフィックスの明示的な広告の必要性を排除するために、これを行うことが推奨されます。

3.1. 基本概念とプレフィックス記法 (Basic Concept and Prefix Notation)​

最も単純な意味において、クラスA/B/Cネットワーク番号からクラスレスプレフィックスへの移行は、32ビットIPv4アドレス内のどのビットがサイトに関連付けられたネットワーク番号 (またはプレフィックス) として解釈され、どのビットがサイト内の個々のエンドシステムの番号付けに使用されるかを明示的にすることです。CIDR表記では、プレフィックスは、従来のIPv4アドレスやネットワーク番号と同様に、4オクテットの量として表現され、その後に文字「/」(スラッシュ) と、有意なビット数を記述する0から32までの10進値が続きます。

例えば、元の「クラスB」ネットワーク172.16.0.0は、暗黙のネットワークマスク255.255.0.0を持ち、プレフィックス172.16.0.0/16として定義されます。「/16」は、プレフィックスのネットワーク部分を抽出するためのマスクが、最上位16ビットが1で最下位16ビットが0である32ビット値であることを示します。同様に、元の「クラスC」ネットワーク番号192.168.99.0は、プレフィックス192.168.99.0/24として定義されます。最上位24ビットが1で、最下位8ビットが0です。

明示的なプレフィックス長を持つクラスレスプレフィックスの使用により、実際のニーズに応じたアドレス空間ブロックのはるかに柔軟な一致が可能になります。以前は3つのネットワークサイズしか利用できませんでしたが、プレフィックスは、1から2^32のエンドシステムアドレスを持つ2の累乗の任意のブロックを記述するように定義できます。実際には、未割り当てアドレスのプールはInternet Assigned Numbers Authority ([IANA]) によって管理されています。IANAは、このプールから地域インターネットレジストリ (Regional Internet Registries) に対して、必要に応じて割り当て (Allocate) を行います。これらの割り当ては、2^24アドレス (プレフィックス/8とも呼ばれる) のビットに沿って整列された連続するブロックの形式で行われます。地域インターネットレジストリ (RIR) は、順次、より小さなアドレスブロックをローカルインターネットレジストリ (LIR) またはインターネットサービスプロバイダ (ISP) に割り当てまたは代入 (Assign) します。これらのエンティティは、割り当てを直接使用することも (ISPの場合に一般的です)、顧客への新しいサブ割り当てを行うこともできます。これらのRIRからのアドレス割り当ては、各ISPまたはLIRのニーズに応じて異なります。例えば、大規模なISPには2^17アドレス (プレフィックス/15) のブロックが割り当てられ、小規模なISPには2^11アドレス (プレフィックス/21) のブロックが割り当てられる場合があります。

「allocate」(割り当て) と「assign」(代入) という用語は、インターネットアドレスレジストリシステムにおいて正確な意味を持つことに注意してください。「allocate」は、さらなるサブ委任を行うことが期待される組織へのアドレス空間ブロックの委任を指し、「assign」は、受け取ったアドレスブロックを直接使用する (つまり個々のホストに番号を付ける) サイトに使用されます。

次の表は、すべてのCIDRプレフィックスサイズの便宜的な参照を提供し、各プレフィックス内の可能なアドレス数と、32ビットIPv4アドレス空間でそのサイズのプレフィックスを何個番号付けできるかを示します:

notation       addrs/block      # blocks

-------- ----------- ----------

n.n.n.n/32 1 4294967296 "host route"

n.n.n.x/31 2 2147483648 "p2p link"

n.n.n.x/30 4 1073741824

n.n.n.x/29 8 536870912

n.n.n.x/28 16 268435456

n.n.n.x/27 32 134217728

n.n.n.x/26 64 67108864

n.n.n.x/25 128 33554432

n.n.n.0/24 256 16777216 legacy "Class C"

n.n.x.0/23 512 8388608

n.n.x.0/22 1024 4194304

n.n.x.0/21 2048 2097152

n.n.x.0/20 4096 1048576

n.n.x.0/19 8192 524288

n.n.x.0/18 16384 262144

n.n.x.0/17 32768 131072

n.n.0.0/16 65536 65536 legacy "Class B"

n.x.0.0/15 131072 32768

n.x.0.0/14 262144 16384

n.x.0.0/13 524288 8192

n.x.0.0/12 1048576 4096

n.x.0.0/11 2097152 2048

n.x.0.0/10 4194304 1024

n.x.0.0/9 8388608 512

n.0.0.0/8 16777216 256 legacy "Class A"

x.0.0.0/7 33554432 128

x.0.0.0/6 67108864 64

x.0.0.0/5 134217728 32

x.0.0.0/4 268435456 16

x.0.0.0/3 536870912 8

x.0.0.0/2 1073741824 4

x.0.0.0/1 2147483648 2

0.0.0.0/0 4294967296 1 "default route"

nは8ビットの10進値です。ポイントツーポイントリンクについては、[RFC3021] で詳しく説明されています。

xは、プレフィックス長に基づく1〜7ビットの値で、オクテットの最上位ビットにシフトされ、10進形式に変換されます。オクテットの最下位ビットはゼロです。

実際には、長さが8未満のプレフィックスはこれまで割り当ても代入もされていませんが、積極的な集約が実行される場合、そのような短いプレフィックスへのルートがルーティングテーブルに存在する可能性があります。本書の執筆時点では、そのようなルートはグローバルルーティングシステムで観測されていませんが、オペレーターのエラーやその他のイベントにより、過去のある時点でいくつか (つまり128.0.0.0/1や192.0.0.0/2) が特定のネットワークで観測されたことがあります。