Passa al contenuto principale

3. Overview

Questo documento aggiorna IPv6 Neighbor Discovery e le specifiche 6LoWPAN/RPL correlate per consentire a un nodo di registrare un IPv6 prefix presso router vicini. I dettagli di protocollo essenziali sono conservati sotto dal testo RFC.

3.  Overview

   This specification inherits from [RFC6550], [RFC8505], and [RFC9010]
   to register prefixes as opposed to addresses.

   The IPv6 ND operation is agnostic to the routing protocol used in the
   SND.  Route-over LLNs typically leverage RPL.  A RPL-based SND
   deployment consists of:

   *  one or more 6LBRs that act as RPL Root,

   *  intermediate routers down the RPL graph that propagate routing
      information on addresses and prefixes towards the Root,

   *  6LRs that are RPL-aware 6LNs and can leverage RPL directly to
      expose their addresses and prefixes, and

   *  6LNs that are the RPL-unaware destinations and need SND to obtain
      reachability over the RPL LLN for their addresses and, with this
      specification, their prefixes as well.

   The SND operation for prefixes inherits from that for unicast
   addresses, meaning that it is the same unless specified otherwise
   herein.  In particular, forwarding a packet happens as specified in
   Section 11 of [RFC6550], including loop avoidance and detection.
   However, in the case of multicast, multiple copies might be
   generated.

   [RFC8505] is a prerequisite to this specification.  A node that
   implements this MUST also implement [RFC8505].  This specification
   does not introduce a new option; it modifies existing options and
   updates the associated behaviors to enable the registration for
   prefixes as an extension to [RFC8505].

   This specification updates the P-Field introduced in [RFC9685] for
   use in EARO, DAR, and RTO, with the new value of 3 to indicate the
   registration of a prefix, as detailed in Section 7.2.  With this
   extension, the 6LN can now express its willingness to receive the
   traffic for all addresses in the range of a prefix, using the P-Field
   value of 3 in the EARO to signal that the registration is for such
   prefix.  Multiple 6LNs acting as border routers to the same external
   network or as access routers to the same subnet may register the same
   prefix to the same 6LR or to different 6LRs.

   If the R flag is set in the registration of one or more 6LNs for the
   same prefix, then, according to its redistribution policy, the 6LR
   MUST redistribute the prefix in the routing protocol(s) (e.g., RPL)
   that it participates in.  The duration of the redistribution is based
   on the longest registration lifetime across the non-expired received
   registrations for the prefix.`

   Examples of use cases where this specification may apply include
   virtual links, shared links, and hub links as shown in Sections 12.3
   and 12.4, respectively.  More generally, the 6LN may be a router
   running a different routing protocol in an external network, e.g., a
   stub network, and acting as a border router.  Using the prefix
   registration method enables decoupling the routing protocol in the
   6LN from the routing protocol that the 6LRs run in the main LLN and
   provide signaling to stimulate the redistribution.