Passa al contenuto principale

9. Changes from Version 2 of the RFC Editor Model

This section preserves the RFC text for the RFC Editor Model, including RSWG, RSAB, RPC, RSCE, IETF LLC, Editorial Stream, appeals, policy implementation, and historical RFC Series properties.

Original RFC Text​

9.  Changes from Version 2 of the RFC Editor Model

   The processes and organizational models for publication of RFCs have
   changed significantly over the years.  Most recently, in 2009,
   [RFC5620] defined the RFC Editor Model (Version 1), and in 2012,
   [RFC6635] defined the RFC Editor Model (Version 2), which was then
   modified slightly in 2020 by [RFC8728].

   However, the community experienced several problems with versions 1
   and 2, including a lack of transparency, a lack of avenues for
   community input into policy definition, and unclear lines of
   authority and responsibility.

   To address these problems, in 2020, the IAB formed the RFC Editor
   Future Development Program to conduct a community discussion and
   consensus process for the further evolution of the RFC Editor Model.
   Under the auspices of this Program, the community considered changes
   that would increase transparency and community input regarding the
   definition of policies for the RFC Series as a whole, while at the
   same time ensuring the continuity of the RFC Series, maintaining the
   quality and timely publication of RFCs, ensuring document
   accessibility, and clarifying lines of authority and responsibility.

   [RFC9280] was the result of discussion within the original Program
   and described version 3 of the RFC Editor Model while remaining
   consistent with [RFC8729].  As stated earlier, this document
   obsoletes [RFC9280].

   The following sections describe the changes from version 2 in more
   detail.

9.1.  RFC Editor Function

   Several responsibilities previously assigned to the RFC Editor (or
   more precisely, the RFC Editor function) are now performed by the
   RSWG, RSAB, RPC, RSCE, and IETF LLC (alone or in combination).  These
   include various aspects of strategic leadership (Section 2.1.1 of
   [RFC8728]), representation of the RFC Series (Section 2.1.2 of
   [RFC8728]), development of RFC production and publication
   (Section 2.1.3 of [RFC8728]), development of the RFC Series
   (Section 2.1.4 of [RFC8728]), operational oversight (Section 3.3 of
   [RFC8729]), policy oversight (Section 3.4 of [RFC8729]), the editing,
   processing, and publication of documents (Section 4.2 of [RFC8729]),
   and development and maintenance of guidelines and rules that apply to
   the RFC Series (Section 4.4 of [RFC8729]).  Among other things, this
   changes the dependency on the RFC Series Editor (RSE) included in
   Section 2.2 of [RFC8730] with regard to "coordinating work and
   conforming to general RFC Series policies as specified by the IAB and
   RSE."  In addition, various details regarding these responsibilities
   have been modified to accord with the framework defined in this
   document.

9.2.  RFC Series Editor

   Implied by the changes outlined in the previous section, the
   responsibilities of the RFC Series Editor (RSE) as a person or role
   (contrasted with the overall RFC Editor function) are now split or
   shared among the RSWG, RSAB, RSCE, RPC, and IETF LLC (alone or in
   combination).  More specifically, the responsibilities of the RFC
   Series Consulting Editor (RSCE) under version 3 of the RFC Editor
   Model differ in many ways from the responsibilities of the RFC Series
   Editor under version 2 of the RFC Editor Model.  In general,
   references in existing documents to the RSE can be taken as referring
   to the RFC Editor function as described herein but should not be
   taken as referring to the RSCE.

9.3.  RFC Publisher

   In practice, the RFC Production Center (RPC) and RFC Publisher roles
   have been performed by the same entity, and this practice is expected
   to continue; therefore, this document dispenses with the distinction
   between these roles and refers only to the RPC.

9.4.  IAB

   Under earlier versions of the RFC Editor Model, the IAB was
   responsible for oversight of the RFC Series and acted as a body for
   final conflict resolution regarding the RFC Series.  The IAB's
   authority in these matters is described in the IAB Charter
   ([RFC2850], as updated by [RFC9283]).  Under version 2 of the RFC
   Editor Model, the IAB delegated some of its authority to the RFC
   Series Oversight Committee (see Section 9.5).  Under version 3 of the
   RFC Editor Model, authority for policy definition resides with the
   RSWG as an independent venue for work by members of the community
   (with approval of policy proposals being the responsibility of the
   RSAB, which represents the streams and includes the RSCE), whereas
   authority for policy implementation resides with the IETF LLC.

9.5.  RFC Series Oversight Committee (RSOC)

   In practice, the relationships and lines of authority and
   responsibility between the IAB, RSOC, and RSE proved unwieldy and
   somewhat opaque.  To overcome some of these issues, [RFC9280]
   dispensed with the RSOC.  References to the RSOC in documents such as
   [RFC8730] are obsolete.

9.6.  RFC Series Advisory Group (RSAG)

   Version 1 of the RFC Editor Model [RFC5620] specified the existence
   of the RFC Series Advisory Group (RSAG), which was no longer
   specified in version 2 of the RFC Editor Model.  For the avoidance of
   doubt, [RFC9280] affirmed that the RSAG was disbanded.  (The RSAG is
   not to be confused with the RFC Series Approval Board (RSAB), which
   this document specifies.)

9.7.  Editorial Stream

   This document specifies the Editorial Stream in addition to the
   streams already described in [RFC8729].