Passa al contenuto principale

6. Conformita RDAP

Questa sezione conserva il testo della RFC sulla ricerca RIR RDAP, inclusi rirSearch1, ips, autnums, ipSearchResults, autnumSearchResults, link di relazione, esempi JSON, comportamento delle risposte, ricerca inversa, conformita e registrazioni IANA.

Testo originale della RFC​

6.  Conformita RDAP

   Un server che supporta la funzionalita specificata in questo documento
   MUST includere letterali stringa aggiuntivi nell'array
   rdapConformance delle sue risposte, secondo quanto segue:

   *  qualsiasi risposta che include un link di ricerca di base per rete
      IP, un link di ricerca per relazione di rete IP o un link di
      ricerca inversa di rete IP include i letterali "rirSearch1" e
      "ips";

   *  qualsiasi risposta a una richiesta di ricerca di base per rete IP,
      di ricerca per relazione di rete IP o di ricerca inversa di rete IP
      include i letterali "rirSearch1", "ips" e "ipSearchResults";

   *  qualsiasi risposta che include un link di ricerca di base ASN, un
      link di ricerca per relazione ASN o un link di ricerca inversa ASN
      include i letterali "rirSearch1" e "autnums";

   *  qualsiasi risposta a una richiesta di ricerca di base ASN, di
      ricerca per relazione ASN o di ricerca inversa ASN include i
      letterali "rirSearch1", "autnums" e "autnumSearchResults";

   *  qualsiasi risposta che include un link di ricerca per relazione di
      dominio include il letterale "rirSearch1";

   *  qualsiasi risposta a una richiesta di ricerca per relazione di
      dominio include il letterale "rirSearch1"; e

   *  una risposta a una richiesta "/help" include i letterali
      "rirSearch1", "ips", "ipSearchResults", "autnums" e
      "autnumSearchResults".

   Sebbene le risposte generalmente non includeranno tutti i letterali
   stringa rdapConformance definiti in questo documento, cio non intende
   implicare che un server possa supportare solo una parte della
   funzionalita definita in questo documento.

   Gli identificatori di estensione "ips", "autnums", "ipSearchResults"
   e "autnumSearchResults" sono inclusi qui a causa dei requisiti e delle
   raccomandazioni stabiliti in [RFC7480], [RFC9082] e [RFC9083].  Tali
   requisiti e raccomandazioni prevedono che un identificatore di
   estensione RDAP sia usato come prefisso nei nuovi segmenti di percorso
   e nei membri JSON introdotti dall'estensione, e tali stringhe sono
   usate come tali nell'ambito delle ricerche di base definite in questo
   documento.  Inoltre, usare queste stringhe come segmenti di percorso
   aiuta ad aumentare la coerenza tra le ricerche di base per le classi
   di oggetti RDAP principali.

   Come per le altre classi di oggetti principali (entity, domain e
   nameserver), altri documenti possono definire ulteriori ricerche
   inverse con reti IP e ASN come tipo di risorsa ricercabile,
   registrandole nei registri IANA RDAP reverse search.  Tuttavia, poiche
   un dato identificatore di estensione deve corrispondere a una singola
   estensione, qualsiasi documento che usi reti IP o ASN come tipo di
   risorsa ricercabile deve anche implementare la funzionalita descritta
   in questo documento.

   Il "1" in "rirSearch1" indica che questa e la versione 1
   dell'estensione di ricerca RIR.  Le nuove versioni dell'estensione di
   ricerca RIR useranno identificatori di estensione diversi.  Un
   suffisso di versione non e usato per i restanti identificatori definiti
   da questo documento, in parte perche tale suffisso ridurrebbe la
   coerenza con la funzionalita corrispondente per le altre classi di
   oggetti principali e in parte perche e molto improbabile che la
   funzionalita associata a tali identificatori cambi.