Passa al contenuto principale

1. Introduzione

Questa sezione conserva il testo della RFC sugli attributi CSR EST, inclusi OID e valori degli attributi CSR, sintassi ASN.1, id-ExtensionReq, CertificationRequestInfoTemplate, esempi Base64, output di dump ASN.1, registrazioni IANA e considerazioni di sicurezza.

Testo originale della RFC​

1.  Introduzione

   Questo documento aggiorna RFC 7030 e chiarisce come la risposta
   Certificate Signing Request (CSR) Attributes possa essere usata da un
   server EST per specificare sia gli OID degli attributi CSR sia i valori
   degli attributi CSR.  In particolare, il server deve poter specificare
   i valori delle estensioni X.509 che si aspetta che il client includa
   nella CSR successiva.

   "Enrollment over Secure Transport" [RFC7030] e stato usato in una
   vasta gamma di applicazioni.  In particolare, [RFC8994] e [RFC8995]
   descrivono un modo per usarlo al fine di costruire un Autonomic
   Control Plane (ACP) [RFC8368].

   Durante il bootstrap dell'ACP, e richiesto che a ciascun nodo venga
   assegnato un subjectAltName molto specifico.  In [RFC8994], la
   specifica ACP, il server EST e specificato come utilizzatore della
   richiesta CSR Attributes ("/csrattrs") (specificata in [RFC7030],
   Section 2.6) per comunicare al client EST il subjectAltName effettivo
   che deve entrare nella sua CSR e quindi, in ultima analisi, nel suo
   certificato End Entity (EE).

   A seguito di alcune difficolta di implementazione, e emerso che questo
   particolare modo di usare i CSR Attributes non era universalmente
   condiviso, ed e stato suggerito che fosse contrario a [RFC7030],
   Section 2.6.

   [RFC7030], Section 2.6 afferma che i CSR Attributes "can provide
   additional descriptive information that the EST server cannot access
   itself".  Questo viene esteso per descrivere come il server EST possa
   fornire valori di cui richiede l'uso.

   Dopo una discussione significativa, e stato determinato che la
   Section 4.5 di [RFC7030] e sufficientemente difficile da leggere e
   ambigua da interpretare da richiedere un chiarimento.

   Inoltre, [RFC7030], Section 4.5.2 e estesa per chiarire l'uso della
   sintassi ASN.1 esistente [X.680] [X.690].

   Cio copre tutti gli usi ed e pienamente retrocompatibile con l'uso
   esistente, inclusa la risposta alle esigenze di [RFC8994] e [RFC8995].