Passa al contenuto principale

1. Introduction (Introduzione)

1. Introduction (Introduzione)​

Gli algoritmi GOST R 34.10-2001 e GOST R 34.11-94 sono documentati in [RFC5933] e il loro utilizzo con le DNS Security Extensions (Estensioni di sicurezza DNS, DNSSEC) è ulteriormente descritto in [RFC9364]. Questi due algoritmi sono stati deprecati dagli ordini dell'Agenzia federale russa per la regolamentazione tecnica e la metrologia (Rosstandart) nell'agosto 2012 e sono stati sostituiti rispettivamente da GOST 34.10-2012 e GOST 34.11-2012. L'uso di questi due nuovi algoritmi in DNSSEC è documentato in [RFC9558] e i loro livelli di requisiti associati non vengono modificati da questo documento.

Pertanto, l'uso di GOST R 34.10-2001 (mnemonico "ECC-GOST") e GOST R 34.11-94 non è più raccomandato per l'uso in DNSSEC [RFC9364].


1.1 Requirements Notation (Notazione dei requisiti)​

Le parole chiave "MUST" (DEVE), "MUST NOT" (NON DEVE), "REQUIRED" (RICHIESTO), "SHALL", "SHALL NOT", "SHOULD" (DOVREBBE), "SHOULD NOT" (NON DOVREBBE), "RECOMMENDED" (RACCOMANDATO), "NOT RECOMMENDED" (NON RACCOMANDATO), "MAY" (PUÒ) e "OPTIONAL" (OPZIONALE) in questo documento devono essere interpretate come descritto in BCP 14 [RFC2119] [RFC8174] quando, e solo quando, appaiono in maiuscolo, come mostrato qui.