Passa al contenuto principale

1. Panoramica (Overview)

Questo documento definisce un modello di dati YANG [RFC7950] che può essere utilizzato per configurare e gestire le estensioni di routing di segmento (Segment Routing extensions) OSPFv2 [RFC2328][RFC8665] e OSPFv3 [RFC5340][RFC8666] sul piano dati MPLS. Il modello di dati YANG definito è un'estensione del modello di dati YANG OSPF [RFC9129].

1.1. Linguaggio dei requisiti (Requirements Language)​

Le parole chiave "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY" e "OPTIONAL" in questo documento devono essere interpretate come descritto in BCP 14 [RFC2119][RFC8174] quando, e solo quando, appaiono in maiuscolo, come mostrato qui.

1.2. Diagrammi ad albero (Tree Diagrams)​

Questo documento utilizza la rappresentazione grafica dei modelli di dati definita in [RFC8340].

Panoramica del modulo YANG​

Il modulo YANG ietf-ospf-sr-mpls contiene le estensioni di routing di segmento del piano dati MPLS sia per OSPFv2 [RFC8665] che per OSPFv3 [RFC8666].

Caratteristiche principali​

Questo modulo YANG fornisce le seguenti capacità principali:

  1. Supporto per OSPFv2 e OSPFv3 - Un modello di dati unificato supporta le estensioni di routing di segmento per entrambe le versioni OSPF
  2. Supporto completo per la configurazione - Include la configurazione del routing di segmento a livello di istanza, area e interfaccia
  3. Informazioni sullo stato LSA - Fornisce dati sullo stato operativo per le informazioni relative al routing di segmento negli annunci di stato del collegamento (Link State Advertisements, LSA) OSPF

Dipendenze del modulo​

Il modulo YANG ietf-ospf-sr-mpls richiede il seguente supporto:

  • Modulo di routing di segmento di base [RFC9020] - Definisce la configurazione globale del routing di segmento indipendentemente da qualsiasi protocollo di routing specifico
  • Modello di base OSPF [RFC9129] - Definisce la configurazione e lo stato di base di OSPF
  • Modulo LSA esteso OSPFv3 [RFC9587] - Modello di dati per LSA estesi OSPFv3

La configurazione OSPF include​

  1. Configurazione a livello di istanza OSPF - Importata dal modulo YANG "ietf-segment-routing-mpls", inclusi i binding del server di mappatura e il blocco globale di routing di segmento (Segment Routing Global Block, SRGB) per protocollo
  2. Configurazione a livello di area OSPF - Abilitare SR-MPLS su tutte le interfacce e pubblicizzare informazioni SR-MPLS negli LSA
  3. Configurazione a livello di interfaccia OSPF - Configurazione degli identificatori di segmento di adiacenza (Adjacency Segment Identifiers, Adj-SID) per vicini specifici su interfacce ad accesso multiplo
  4. Configurazione TI-LFA - Configurazione a livello di interfaccia dell'alternativa senza loop indipendente dalla topologia (Topology-Independent Loop-Free Alternate) utilizzando il piano dati MPLS

Stato operativo LSA​

Il modulo fornisce aggiunte di stato operativo (sola lettura) per LSA OSPFv2 e OSPFv3:

Specifico per OSPFv2:

  • Codifica TLV intervallo prefisso esteso
  • Codifica sub-TLV Prefix-SID
  • Algoritmo SR, TLV intervallo SID/Label, ecc.

Specifico per OSPFv3:

  • Codifica TLV intervallo prefisso esteso
  • Codifica sub-TLV Prefix-SID
  • Sub-TLV Adj-SID e LAN Adj-SID
  • Algoritmo SR, TLV intervallo SID/Label, ecc.

Attraverso questo modello YANG, gli operatori di rete possono configurare e gestire le capacità di routing di segmento nelle reti OSPF utilizzando un approccio standardizzato, consentendo capacità di ingegneria del traffico flessibile e di rerouting veloce.