Passa al contenuto principale

7. Security Considerations (Considerazioni sulla Sicurezza)

7. Security Considerations (Considerazioni sulla Sicurezza)​

Questo documento specifica un'estensione del formato di messaggio per SCHC. Pertanto, si applicano le stesse considerazioni sulla sicurezza definite in [RFC8724] e [RFC9363].

Il modulo YANG specificato in questo documento definisce uno schema per i dati che è progettato per essere accessibile tramite protocolli di gestione di rete come NETCONF [RFC6241] o RESTCONF [RFC8040]. Il livello NETCONF più basso è il livello di trasporto sicuro, e il trasporto sicuro obbligatorio da implementare è Secure Shell (SSH) [RFC6242]. Il livello RESTCONF più basso è HTTPS, e il trasporto sicuro obbligatorio da implementare è TLS [RFC8446].

Il Network Configuration Access Control Model (NACM) (Modello di Controllo dell'Accesso alla Configurazione di Rete) [RFC8341] fornisce i mezzi per limitare l'accesso per particolari utenti NETCONF o RESTCONF a un sottoinsieme preconfigurato di tutte le operazioni di protocollo NETCONF o RESTCONF disponibili e del contenuto.

Ci sono un certo numero di nodi dati definiti in questo modulo YANG che sono scrivibili/creabili/eliminabili (cioè config true, che è il valore predefinito). Questi nodi dati possono essere considerati sensibili o vulnerabili in alcuni ambienti di rete. Le operazioni di scrittura (ad esempio, edit-config) su questi nodi dati senza un'adeguata protezione possono avere un effetto negativo sulle operazioni di rete. Questi sono i sottoalberi e i nodi dati e la loro sensibilità/vulnerabilità:

/schc:schc/schc:rule/schc:nature/schc:fragmentation/schc:mode/schc:ack-on-error:

Tutti i nodi dati possono essere modificati. La Rule contiene informazioni sensibili, come la configurazione e l'utilizzo della modalità SCHC F/R e la configurazione dello SCHC Compound ACK. Un attaccante può tentare di modificare le Rules di altri dispositivi cambiando la modalità F/R o l'utilizzo dello SCHC Compound ACK e può bloccare la comunicazione o creare ACK aggiuntivi. Pertanto, a un dispositivo deve essere consentito modificare solo le proprie Rules sull'istanza SCHC remota. L'identità del richiedente deve essere validata. Questo può essere fatto tramite certificati o liste di accesso.

Alcuni dei nodi dati leggibili in questo modulo YANG possono essere considerati sensibili o vulnerabili in alcuni ambienti di rete. È quindi importante controllare l'accesso in lettura (ad esempio, tramite get, get-config o notification) a questi nodi dati. Questi sono i sottoalberi e i nodi dati e la loro sensibilità/vulnerabilità:

/schc:schc/schc:rule/schc:nature/schc:fragmentation/schc:mode/schc:ack-on-error:

Leggendo questo modulo, un attaccante può apprendere la modalità F/R utilizzata dal dispositivo, come il dispositivo gestisce la creazione del bitmap, le dimensioni del buffer e quando il dispositivo richiederà un ACK.