Passa al contenuto principale

1. Introduzione (Introduction)

L'Hypertext Transfer Protocol (HTTP) è un protocollo di richiesta/risposta senza stato a livello di applicazione che utilizza semantica estensibile e messaggi auto-descrittivi per un'interazione flessibile con sistemi informativi ipertestuali basati sulla rete. HTTP/1.1 è definito da:

  • Questo documento
  • "HTTP Semantics" [HTTP]
  • "HTTP Caching" [CACHING]

Questo documento specifica come la semantica HTTP viene trasmessa utilizzando la sintassi dei messaggi HTTP/1.1, il framing e i meccanismi di gestione delle connessioni.

1.1. Notazione dei requisiti (Requirements Notation)​

Le parole chiave "DEVE" (MUST), "NON DEVE" (MUST NOT), "RICHIESTO" (REQUIRED), "DOVRÀ" (SHALL), "NON DOVRÀ" (SHALL NOT), "DOVREBBE" (SHOULD), "NON DOVREBBE" (SHOULD NOT), "RACCOMANDATO" (RECOMMENDED), "PUÒ" (MAY) e "OPZIONALE" (OPTIONAL) in questo documento devono essere interpretate come descritto in BCP 14 [RFC2119] [RFC8174].

1.2. Notazione sintattica (Syntax Notation)​

Questa specifica utilizza la notazione Augmented Backus-Naur Form (ABNF) di [RFC5234], estesa con la notazione per la sensibilità alle maiuscole/minuscole nelle stringhe definita in [RFC7405].

Le seguenti regole principali sono incluse per riferimento, come definito in [RFC5234], Appendice B.1: ALPHA (lettere), CR (ritorno a capo), CRLF (CR LF), CTL (caratteri di controllo), DIGIT (decimale 0-9), DQUOTE (virgolette doppie), HEXDIG (esadecimale 0-9/A-F/a-f), HTAB (tabulazione orizzontale), LF (avanzamento riga), OCTET (qualsiasi sequenza di dati a 8 bit), SP (spazio) e VCHAR (qualsiasi carattere visibile [USASCII]).

BWS           = <BWS, vedere [HTTP], Sezione 5.6.3>
OWS = <OWS, vedere [HTTP], Sezione 5.6.3>
RWS = <RWS, vedere [HTTP], Sezione 5.6.3>
absolute-path = <absolute-path, vedere [HTTP], Sezione 4.1>
field-name = <field-name, vedere [HTTP], Sezione 5.1>
field-value = <field-value, vedere [HTTP], Sezione 5.5>