Passa al contenuto principale

RFC 8314 - Il testo in chiaro considerato obsoleto: uso di TLS per submission e accesso alla posta

  • Stato: Proposed Standard
  • Pubblicato: January 2018
  • Stream: IETF
  • Aggiorna: RFC1939, RFC2595, RFC3501, RFC5068, RFC6186, RFC6409
  • Errata: Nessun errata

Informazioni sul documento​

  • Numero RFC: 8314
  • Titolo: Cleartext Considered Obsolete: Use of TLS for Email Submission and Access
  • Autori: K. Moore, C. Newman
  • Data: January 2018
  • Categoria: Best Current Practice
  • ISSN: 2070-1721

Sommario (Abstract)​

Il presente documento richiede che i protocolli di accesso alla posta (POP, IMAP) e i protocolli di submission della posta (SMTP submission) siano protetti da TLS (Transport Layer Security) e che l'uso del testo in chiaro per questi protocolli sia deprecato.

Stato di questo memo​

Questo memo documenta una Internet Best Current Practice.

Il presente documento è un prodotto dell'Internet Engineering Task Force (IETF). Rappresenta il consenso della comunità IETF. Ha ricevuto revisione pubblica ed è stato approvato per la pubblicazione dall'Internet Engineering Steering Group (IESG). Ulteriori informazioni sui BCP sono disponibili nella Sezione 2 di RFC 7841.

Informazioni sullo stato corrente di questo documento, eventuali errata e su come fornire feedback sono disponibili all'indirizzo https://www.rfc-editor.org/info/rfc8314.

Copyright (c) 2018 IETF Trust and the persons identified as the document authors. All rights reserved.

Il presente documento è soggetto a BCP 78 e alle disposizioni legali dell'IETF Trust relative ai documenti IETF (https://trustee.ietf.org/license-info) in vigore alla data di pubblicazione di questo documento. Si prega di esaminare attentamente tali documenti, poiché descrivono i diritti e le restrizioni relativi a questo documento. I componenti di codice estratti da questo documento devono includere il testo della Simplified BSD License descritto nella Sezione 4.e delle Trust Legal Provisions e sono forniti senza garanzia come descritto nella Simplified BSD License.

Indice​

  1. Introduzione
  2. Terminologia
  3. Deprecazione del testo in chiaro
  4. Protocolli specifici
  5. Considerazioni sulla sicurezza
  6. Considerazioni IANA
  7. Riferimenti

1. Introduzione​

L'uso di comunicazione in chiaro (non cifrata) per i protocolli di posta (POP, IMAP, SMTP Submission) espone le credenziali utente e il contenuto della posta all'intercettazione. Il presente documento specifica che TLS MUST essere usato per questi protocolli.

2. Terminologia​

Le parole chiave "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY" e "OPTIONAL" nel presente documento devono essere interpretate come descritto in BCP 14 [RFC2119] [RFC8174] quando, e solo quando, appaiono tutte in maiuscolo.

3. Deprecazione del testo in chiaro​

3.1. Mail User Agents (MUA)​

I MUA MUST configurare TLS per tutte le sessioni di submission e accesso alla posta.

3.2. Mail Service Providers (MSP)​

Gli MSP MUST fornire TLS per tutti i servizi di submission e accesso alla posta. Gli MSP SHOULD deprecare e disabilitare l'accesso in chiaro.

3.3. Uso di TLS 1.2 o superiore​

Le implementazioni MUST supportare TLS 1.2 [RFC5246] o superiore.

4. Protocolli specifici​

4.1. IMAP​

I server IMAP MUST supportare TLS implicito sulla porta 993. STARTTLS sulla porta 143 è pure consentito, ma il TLS implicito è preferito.

4.2. POP​

I server POP MUST supportare TLS implicito sulla porta 995. STARTTLS sulla porta 110 è pure consentito, ma il TLS implicito è preferito.

4.3. SMTP Submission​

I server SMTP Submission MUST supportare TLS implicito sulla porta 465. STARTTLS sulla porta 587 è pure consentito.

5. Considerazioni sulla sicurezza​

Il presente documento affronta i rischi di sicurezza dell'uso del testo in chiaro per i protocolli di posta. Impone l'uso di TLS per proteggere confidenzialità e integrità.

6. Considerazioni IANA​

Il presente documento non richiede azioni IANA.

7. Riferimenti​

  • [RFC2119] Bradner, S., "Key words for use in RFCs to Indicate Requirement Levels", BCP 14, RFC 2119, March 1997.
  • [RFC5246] Dierks, T. and E. Rescorla, "The Transport Layer Security (TLS) Protocol Version 1.2", RFC 5246, August 2008.
  • [RFC8174] Leiba, B., "Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words", BCP 14, RFC 8174, May 2017.

Indirizzi degli autori

Keith Moore Network Heretics

Email: [email protected]

Chris Newman Oracle

Email: [email protected]