Passa al contenuto principale

Appendice C. Modifiche rispetto alla RFC 3406

Questo documento apporta le seguenti modifiche sostanziali rispetto alla RFC 3406:

1. Politica di registrazione alleggerita​

Alleggerisce la politica di registrazione per gli spazi dei nomi URN formali da "IETF Review" (Revisione IETF) a "Expert Review" (Revisione esperta) come discusso nella sezione 6.2.

Impatto​

  • Semplifica il processo di registrazione per gli spazi dei nomi formali
  • Abbassa la soglia di registrazione
  • Accelera la velocità di approvazione
  • Mantiene il controllo di qualità necessario

2. Rimozione della categoria di spazi dei nomi sperimentali​

Rimuove la categoria degli spazi dei nomi URN sperimentali, coerentemente con la RFC 6648.

Caratteristiche degli spazi dei nomi sperimentali​

  • Gli spazi dei nomi URN sperimentali erano denotati prefissando l'identificatore dello spazio dei nomi con la stringa "X-"
  • Gli spazi dei nomi URN sperimentali non sono mai stati registrati

Impatto della rimozione​

  • La rimozione della categoria sperimentale non ha impatto sui registri esistenti
  • Poiché gli spazi dei nomi URN sperimentali non sono gestiti, le stringhe conformi alla sintassi URN all'interno di spazi dei nomi URN sperimentali non sono URN validi
  • Gli usi veramente sperimentali possono, naturalmente, impiegare lo spazio dei nomi "example" (RFC 6963)

3. Modello di registrazione semplificato​

Miglioramenti al modello di registrazione degli spazi dei nomi URN:

  • Aggiunge alcuni campi di informazioni
  • Semplifica generalmente la struttura del modello
  • Rende il processo di registrazione più chiaro e più facile da utilizzare

Riepilogo delle modifiche alle politiche​

Lo scopo di queste modifiche è:

  • Rendere la registrazione degli spazi dei nomi URN più pratica ed efficiente
  • Allinearsi alle moderne migliori pratiche IETF
  • Ridurre il carico amministrativo non necessario
  • Migliorare l'esperienza utente complessiva