Passa al contenuto principale

6. IANA Considerations (Considerazioni IANA)

6. IANA Considerations (Considerazioni IANA)​

L'IANA ha creato un registro di etichette di esportatore TLS per questo scopo. Il contenuto iniziale del registro è riportato di seguito:

Valore (Value)Riferimento (Reference)Nota (Note)
client finished[RFC5246](1)
server finished[RFC5246](1)
master secret[RFC5246](1)
key expansion[RFC5246](1)
client EAP encryption[RFC5216]
ttls keying material[RFC5281]
ttls challenge[RFC5281]

Nota: (1) Queste voci sono riservate e NON DEVONO essere utilizzate per lo scopo descritto in RFC 5705, al fine di evitare confusione con un uso simile, ma distinto, in RFC 5246.

I valori futuri sono allocati tramite la politica Specification Required del RFC 5226. L'etichetta è una stringa composta da caratteri ASCII stampabili. L'IANA DEVE anche verificare che un'etichetta non sia un prefisso di qualsiasi altra etichetta. Ad esempio, le etichette "key" o "master secretary" sono vietate.