Passa al contenuto principale

8. Considerazioni IANA (IANA Considerations)

IANA mantiene tre registri a supporto di questa specifica, tutti creati per RFC 2821 o versioni precedenti. Questo documento estende il terzo registro come descritto di seguito. I riferimenti ai registri elencati sono quelli disponibili alla data di pubblicazione; IANA non garantisce la stabilità degli URL associati alle posizioni.

8.1. Registro delle estensioni del servizio SMTP​

Il primo registro, "Simple Mail Transfer Protocol (SMTP) Service Extensions", contiene estensioni del servizio SMTP con parole chiave associate e, quando necessario, parametri e verbi. Come specificato nella Sezione 2.2.2, nessuna voce che inizi con "X" può essere inserita in questo registro. Le voci possono essere inserite solo per estensioni del servizio, e per le parole chiave, i parametri o i verbi associati, definite in RFC standards-track o sperimentali approvate specificamente dall'IESG per questo scopo.

8.2. Registro dei tag dei letterali di indirizzo​

Il secondo registro, "Address Literal Tags", contiene i "tag" che identificano forme di letterali di dominio diverse da quelle per indirizzi IPv4, specificate in RFC 821 e in questo documento. La voce iniziale in questo registro riguarda gli indirizzi IPv6, specificati in questo documento. Ulteriori tipi di letterali richiedono standardizzazione prima dell'uso; al momento non sono previsti tipi aggiuntivi.

8.3. Registro dei tipi di trasmissione della posta​

Il terzo registro, "Mail Transmission Types", istituito da RFC 821 e aggiornato da questa specifica, è un registro di identificatori di collegamento e di protocollo da usare con le clausole "via" e "with" del timestamp, cioè il campo header "Received:", descritto nella Sezione 4.4. Oltre agli identificatori di collegamento e protocollo specificati in questo documento, le voci possono essere aggiunte solo tramite standardizzazione o tramite estensioni sperimentali di protocollo documentate in RFC e approvate dall'IESG. Questo spazio dei nomi è usato per l'identificazione e la sua dimensione non è limitata: l'IESG è incoraggiato ad approvare voci basate su documentazione chiara e su un approccio unico, piuttosto che su preferenze circa le proprietà dell'approccio stesso.

Una sottosezione aggiuntiva è stata aggiunta sia alle sottosezioni "VIA link types" sia alle sottosezioni "WITH protocol types" di quel registro per ospitare le registrazioni di "Additional-registered-clauses" come descritto sopra. Il registro conterrà il nome della clausola, una descrizione, un riassunto della sintassi della stringa associata e un riferimento. In linea di principio, quando vengono definite nuove clausole, i documenti che le specificano potrebbero creare registri propri se la stringa è composta da termini riservati o parole chiave invece che da una stringa meno vincolata. Come per gli identificatori di collegamento e protocollo, le clausole aggiuntive possono essere registrate solo tramite standardizzazione o tramite estensioni sperimentali di protocollo documentate in RFC e approvate dall'IESG. Lo spazio dei nomi delle clausole aggiuntive è usato per l'identificazione e la sua dimensione non è limitata: l'IESG è incoraggiato ad approvare voci basate su documentazione chiara, uso effettivo o forte indicazione che la clausola sarà usata, e requisiti unici, piuttosto che su preferenze circa le proprietà della clausola stessa.

Inoltre, se in futuro venissero creati campi header di traccia aggiuntivi, cioè oltre a Return-path e Received, tali campi di traccia devono essere aggiunti al registro IANA per RFC 5322 istituito da BCP 90 (RFC 3864) (MUST).