4. Considerations with Special Types (Considerazioni sui tipi speciali)
4. Considerations with Special Types (Considerazioni sui tipi speciali)
Questo è un riepilogo delle azioni per vari tipi. La maggior parte di queste disposizioni dipende dal fatto che i RR di un tipo possano o meno coesistere. Alcune sono semplicemente osservazioni.
4.1 SOA RRSet at a Wildcard Domain Name
Un nome di dominio wildcard che possiede un SOA RRSet significa che il dominio si trova alla cima della zona ed è un nome di dominio wildcard. Il possesso di record SOA da parte di un nome di dominio wildcard ha un effetto non definito. Per evitare una situazione in cui i wildcard vengano usati per sintetizzare record SOA, un record SOA NON DEVE essere l'unico record presente in un nome di dominio wildcard.
4.2 NS RRSet at a Wildcard Domain Name
Un nome di dominio wildcard non è un punto di delegazione. La sintesi di un NS RRSet non è stata definita. Alcuni precedenti lavori DNS avevano preso in considerazione di consentire la sintesi di punti di delegazione, ma tale possibilità è stata scartata.
4.2.1 Discarded Notions (Nozioni scartate)
L'idea di consentire un nome di dominio wildcard come punto di delegazione significherebbe che per ogni nome non esistente sotto il nome di dominio wildcard verrebbe sintetizzata una delega. Ciò comporterebbe gravi problemi di coerenza nel DNS ed è stato pertanto scartato.
4.3 CNAME RRSet at a Wildcard Domain Name
L'interazione di CNAME e wildcard viene aggiornata nella sezione 3.3.3 di questo documento. Un CNAME RRSet in un nome di dominio wildcard può essere usato solo per sintetizzare record CNAME.
4.4 DNAME RRSet at a Wildcard Domain Name
Il possesso di un DNAME [RFC2672] RRSet da parte di un nome di dominio wildcard rappresenta una minaccia per la coerenza del DNS e dovrebbe essere evitato o addirittura rifiutato.
4.5 SRV RRSet at a Wildcard Domain Name
Non vi è alcun motivo particolare per trattare gli SRV [RFC2782] RRSet in modo diverso dagli altri tipi di RR. Pertanto è possibile la sintesi di un SRV RRSet.
4.6 DS RRSet at a Wildcard Domain Name
Il possesso di un DS [RFC3658] RRSet da parte di un nome di dominio wildcard non è definito. Un record DS in un nome di dominio wildcard avrebbe l'effetto di delegare un dominio che non esiste ancora. Ciò è contrario allo spirito dei record DS e dovrebbe essere evitato.
4.7 NSEC RRSet at a Wildcard Domain Name
Il possesso di un NSEC [RFC4034] RRSet da parte di un nome di dominio wildcard non è definito. Un record NSEC in un nome di dominio wildcard fornirebbe una prova di inesistenza per i nomi sotto il nome di dominio wildcard, contrariamente allo scopo di un nome di dominio wildcard. Ciò dovrebbe essere evitato.
4.8 RRSIG at a Wildcard Domain Name
Il possesso di un record RRSIG [RFC4034] da parte di un nome di dominio wildcard non è definito. Un record RRSIG in un nome di dominio wildcard fornirebbe una firma per un nome che non esiste ancora. Ciò dovrebbe essere evitato.
4.9 Empty Non-terminal Wildcard Domain Name
Il possesso di un nome di dominio wildcard che è un non terminale vuoto (ovvero che non possiede record diversi dal nome di dominio wildcard stesso) non è definito. Un tale nome si comporterebbe come un non terminale vuoto se non avesse record; tuttavia, poiché è un nome di dominio wildcard, dovrebbe sintetizzare record. Il comportamento di un tale nome è pertanto ambiguo e dovrebbe essere evitato.