Passa al contenuto principale

RFC 2181 - Chiarimenti alla specifica DNS

  • Stato: Proposed Standard
  • Pubblicato: July 1997
  • Stream: IETF
  • Aggiorna: RFC1034, RFC1035, RFC1123
  • Errata: Nessun errata

Sommario (Abstract)​

Questo documento esamina alcune aree che sono state identificate come problematiche nella specifica del Domain Name System (DNS) e propone rimedi per i difetti identificati. Vengono considerati otto problemi separati:

  • Uso dell'indirizzo dell'intestazione del pacchetto IP dai server multi-homed
  • TTL negli insiemi di record con lo stesso nome, classe e tipo
  • Gestione corretta dei tagli di zona (Zone Cuts)
  • Tre problemi minori riguardanti i record SOA e il loro utilizzo
  • Definizione precisa del Time to Live (TTL)
  • Uso del bit di intestazione TC (troncato)
  • La questione di cosa sia un nome autoritativo o canonico
  • La questione di cosa costituisce un'etichetta DNS valida

I primi sei sono aree in cui il comportamento corretto è stato piuttosto poco chiaro, cerchiamo di rettificare ciò. Gli altri due sono già adeguatamente specificati, tuttavia le specifiche sembrano essere talvolta ignorate. Cerchiamo di rafforzare le specifiche esistenti.


Indice (Contents)​


Risorse correlate​