7. Appendice III: Bibliografia (Appendix III: Bibliography)
7.0 Appendix III: Bibliography
[Corbin] Corbin, John, "The Art of Distributed Programming-Programming Techniques for Remote Procedure Calls." Springer-Verlag, New York, New York. 1991. Descrizione di base di RPC e XDR e di come utilizzarli per programmare applicazioni distribuite.
[Glover] Glover, Fred, "TNFS Protocol Specification," Trusted System Interest Group, Work in Progress.
[Israel] Israel, Robert K., Sandra Jett, James Pownell, George M. Ericson, "Eliminating Data Copies in UNIX-based NFS Servers," Uniforum Conference Proceedings, San Francisco, CA, February 27 - March 2, 1989. Descrive due metodi per ridurre le copie di dati nel codice dei server NFS.
[Jacobson] Jacobson, V., "Congestion Control and Avoidance," Proc. ACM SIGCOMM `88, Stanford, CA, August 1988. Il documento descrive i miglioramenti a TCP per consentirne l'uso sulle reti geografiche (WAN) e attraverso gateway che collegano reti di capacità variabile. Questo lavoro è stato il punto di partenza per il lavoro di Retransmission dinamica NFS.
[Juszczak] Juszczak, Chet, "Improving the Performance and Correctness of an NFS Server," USENIX Conference Proceedings, USENIX Association, Berkeley, CA, June 1990, pages 53-63. Descrive l'implementazione della reply cache che evita lavoro superfluo nel server gestendo le richieste duplicate. Più importante, sebbene elencato come effetto collaterale, la reply cache aiuta a evitare la riapplicazione di operazioni non idempotenti distruttive, migliorando così la correttezza.
[Kazar] Kazar, Michael Leon, "Synchronization and Caching Issues in the Andrew File System," USENIX Conference Proceedings, USENIX Association, Berkeley, CA, Dallas Winter 1988, pages 27-36. Una descrizione dello schema di coerenza della cache in AFS. Contrastato con altri file system distribuiti.
[Macklem] Macklem, Rick, "Lessons Learned Tuning the 4.3BSD Reno Implementation of the NFS Protocol," Winter USENIX Conference Proceedings, USENIX Association, Berkeley, CA, January 1991. Descrive il lavoro sulle prestazioni relativo all'ottimizzazione dell'implementazione NFS 4.3BSD Reno. Descrive il miglioramento delle prestazioni (riduzione del carico CPU) ottenuto eliminando le copie di dati.
[Mogul] Mogul, Jeffrey C., "A Recovery Protocol for Spritely NFS," USENIX File System Workshop Proceedings, Ann Arbor, MI, USENIX Association, Berkeley, CA, May 1992. Secondo articolo su Spritely NFS, che propone uno schema basato su lease per recuperare lo stato del protocollo di coerenza.
[Nowicki] Nowicki, Bill, "Transport Issues in the Network File System," ACM SIGCOMM newsletter Computer Communication Review, April 1989. Breve descrizione della base del lavoro di retransmission dinamica.
[Pawlowski] Pawlowski, Brian, Ron Hixon, Mark Stein, Joseph Tumminaro, "Network Computing in the UNIX and IBM Mainframe Environment," Uniforum `89 Conf. Proc., (1989) Descrizione di un'implementazione di server NFS per il sistema operativo MVS di IBM.
[RFC1014] Sun Microsystems, Inc., "XDR: External Data Representation Standard", RFC 1014, Sun Microsystems, Inc., June 1987. Specifica del formato canonico per lo scambio di dati, utilizzato con RPC.
[RFC1057] Sun Microsystems, Inc., "RPC: Remote Procedure Call Protocol Specification", RFC 1057, Sun Microsystems, Inc., June 1988. Specifica del protocollo di chiamata di procedura remota.
[RFC1094] Sun Microsystems, Inc., "Network Filesystem Specification", RFC 1094, Sun Microsystems, Inc., March 1989. Specifica del protocollo NFS versione 2.
[Sandberg] Sandberg, R., D. Goldberg, S. Kleiman, D. Walsh, B. Lyon, "Design and Implementation of the Sun Network Filesystem," USENIX Conference Proceedings, USENIX Association, Berkeley, CA, Summer 1985. Il documento di base che descrive l'implementazione SunOS del protocollo NFS versione 2 e discute obiettivi, specifica del protocollo e compromessi.
[Srinivasan] Srinivasan, V., Jeffrey C. Mogul, "Spritely NFS: Implementation and Performance of Cache Consistency Protocols", WRL Research Report 89/5, Digital Equipment Corporation Western Research Laboratory, 100 Hamilton Ave., Palo Alto, CA, 94301, May 1989. Questo documento analizza l'effetto dell'applicazione di un protocollo di coerenza di tipo Sprite al NFS standard. I problemi di recupero in un ambiente con stato sono trattati in [Mogul].
[X/OpenNFS] X/Open Company, Ltd., X/Open CAE Specification: Protocols for X/Open Internetworking: XNFS, X/Open Company, Ltd., Apex Plaza, Forbury Road, Reading Berkshire, RG1 1AX, United Kingdom, 1991. Questa è un'indispensabile referenza per il protocollo NFS versione 2 e i protocolli associati, inclusi il Lock Manager e il Portmapper.
[X/OpenPCNFS] X/Open Company, Ltd., X/Open CAE Specification: Protocols for X/Open Internetworking: (PC)NFS, Developer's Specification, X/Open Company, Ltd., Apex Plaza, Forbury Road, Reading Berkshire, RG1 1AX, United Kingdom, 1991. Questa è un'indispensabile referenza per il protocollo NFS versione 2 e i protocolli associati, inclusi il Lock Manager e il Portmapper.