Zum Hauptinhalt springen

4. Use of the SRH AltMark TLV

Dieser Abschnitt bewahrt den RFC-Text zum SRH AltMark TLV experiment, einschliesslich Alternate-Marking Method, SRv6, SRH, FlowMonID, L and D flags, NH, enhanced fields, controlled-domain requirements, security und IANA considerations.

Originaler RFC-Text​

4.  Use of the SRH AltMark TLV

   Since the measurement domain is congruent with the SR-controlled
   domain, the procedure for AltMark data encapsulation in the SRv6 SRH
   is summarized as follows:

   *  Ingress SR Node: As part of the SRH encapsulation, the Ingress SR
      Node of an SR domain or an SR Policy [RFC9256] that supports the
      mechanisms defined in this document and that wishes to perform the
      Alternate-Marking Method adds the AltMark TLV in the SRH of the
      data packets.

   *  Intermediate SR Node: The Intermediate SR Node is any node
      receiving an IPv6 packet where the destination address of that
      packet is a local Segment Identifier (SID).  If an Intermediate SR
      Node is not capable of processing the AltMark TLV, it simply
      ignores it according to the processing rules of [RFC8754].  If an
      Intermediate SR Node is capable of processing the AltMark TLV, it
      checks if the SRH AltMark TLV is present in the packet and
      processes it.

   *  Egress SR Node: The Egress SR Node is the last node in the segment
      list of the SRH.  The processing of AltMark TLV at the Egress SR
      Node is the same as the processing of AltMark TLV at the
      Intermediate SR Nodes.

   The use of the AltMark TLV may be combined with the network
   programming capability of SRv6 [RFC8986].  Specifically, the ability
   for an SRv6 endpoint to determine whether to process or ignore some
   specific SRH TLVs (such as the AltMark TLV) may be based on the SID
   function associated with the SID advertised by an Intermediate or
   Egress SR Node and used in the Destination Address field of the SRv6
   packet.  When a packet is addressed to a SID that does not support
   the Alternate-Marking functionality, the receiving node does not have
   to look for or process the SRH AltMark TLV and can simply ignore it.
   This also enables collection of Alternate-Marking data only from the
   supporting segment endpoints.

4.1.  Compatibility

   As highlighted in Section 1.1, the use of the Destination Option to
   carry the AltMark data preceding the SRH is equivalent to the SRH
   AltMark TLV.  Therefore, it is important to analyze what happens when
   both the SRH AltMark TLV and the Destination Option are present, and
   how that would impact processing and complexity.

   It is worth mentioning that the SRH AltMark TLV and the Destination
   Option carrying AltMark data can coexist without problems.  If both
   are present, the only issue could be the duplication of information,
   but this will not affect in any way the device and the network
   services.  Both this document and [RFC9343] require a controlled
   domain for security purposes, which confines this duplication to a
   single service provider network.  Duplication of the same information
   in different places should be avoided, and analyzing the use of only
   the SRH AltMark TLV is recommended as part of this experiment.