Zum Hauptinhalt springen

6. RDAP-Konformitaet

Dieser Abschnitt bewahrt den RFC-Text zur RDAP-RIR-Suche, einschliesslich rirSearch1, ips, autnums, ipSearchResults, autnumSearchResults, Relation Links, JSON-Beispielen, Antwortverhalten, Reverse Search, Konformitaet und IANA-Registrierungen.

Originaler RFC-Text​

6.  RDAP-Konformitaet

   Ein Server, der die in diesem Dokument spezifizierte Funktionalitaet
   unterstuetzt, MUST zusaetzliche String-Literale im Array
   rdapConformance seiner Antworten gemaess Folgendem enthalten:

   *  jede Antwort, die einen Basic-Search-Link fuer IP-Netzwerke, einen
      Relation-Search-Link fuer IP-Netzwerke oder einen Reverse-Search-
      Link fuer IP-Netzwerke enthaelt, enthaelt die Literale
      "rirSearch1" und "ips";

   *  jede Antwort auf eine Basic-Search-Anforderung fuer IP-Netzwerke,
      eine Relation-Search-Anforderung fuer IP-Netzwerke oder eine
      Reverse-Search-Anforderung fuer IP-Netzwerke enthaelt die Literale
      "rirSearch1", "ips" und "ipSearchResults";

   *  jede Antwort, die einen Basic-Search-Link fuer ASN, einen
      Relation-Search-Link fuer ASN oder einen Reverse-Search-Link fuer
      ASN enthaelt, enthaelt die Literale "rirSearch1" und "autnums";

   *  jede Antwort auf eine Basic-Search-Anforderung fuer ASN, eine
      Relation-Search-Anforderung fuer ASN oder eine Reverse-Search-
      Anforderung fuer ASN enthaelt die Literale "rirSearch1", "autnums"
      und "autnumSearchResults";

   *  jede Antwort, die einen Relation-Search-Link fuer Domains enthaelt,
      enthaelt das Literal "rirSearch1";

   *  jede Antwort auf eine Relation-Search-Anforderung fuer Domains
      enthaelt das Literal "rirSearch1"; und

   *  eine Antwort auf eine "/help"-Anforderung enthaelt die Literale
      "rirSearch1", "ips", "ipSearchResults", "autnums" und
      "autnumSearchResults".

   Obwohl Antworten im Allgemeinen nicht alle in diesem Dokument
   definierten rdapConformance-String-Literale enthalten werden, soll dies
   nicht bedeuten, dass ein Server nur einen Teil der in diesem Dokument
   definierten Funktionalitaet unterstuetzen kann.

   Die Erweiterungskennungen "ips", "autnums", "ipSearchResults" und
   "autnumSearchResults" sind hier aufgrund der in [RFC7480], [RFC9082]
   und [RFC9083] dargelegten Anforderungen und Empfehlungen enthalten.
   Diese Anforderungen und Empfehlungen sehen vor, dass eine RDAP-
   Erweiterungskennung als Praefix in neuen Pfadsegmenten und JSON-
   Mitgliedern verwendet wird, die durch die Erweiterung eingefuehrt
   werden, und diese Strings werden als solche im Rahmen der in diesem
   Dokument definierten Basic Searches verwendet.  Darueber hinaus hilft
   die Verwendung dieser Strings als Pfadsegmente, die Konsistenz
   zwischen den Basic Searches fuer die zentralen RDAP-Objektklassen zu
   erhoehen.

   Wie bei den anderen zentralen Objektklassen (entity, domain und
   nameserver) koennen andere Dokumente zusaetzliche Reverse Searches mit
   IP-Netzwerken und ASNs als durchsuchbarem Ressourcentyp definieren,
   indem sie diese in den IANA RDAP Reverse-Search-Registern
   registrieren.  Da eine gegebene Erweiterungskennung jedoch einer
   einzigen Erweiterung entsprechen muss, muss jedes Dokument, das
   IP-Netzwerke oder ASNs als durchsuchbaren Ressourcentyp verwendet,
   auch die in diesem Dokument beschriebene Funktionalitaet
   implementieren.

   Die "1" in "rirSearch1" bedeutet, dass dies Version 1 der RIR-
   Sucherweiterung ist.  Neue Versionen der RIR-Sucherweiterung werden
   andere Erweiterungskennungen verwenden.  Fuer die uebrigen durch
   dieses Dokument definierten Kennungen wird kein Versionssuffix
   verwendet, teils weil ein solches Suffix die Konsistenz mit der
   entsprechenden Funktionalitaet fuer die anderen zentralen
   Objektklassen verringern wuerde, und teils weil es sehr
   unwahrscheinlich ist, dass sich die mit diesen Kennungen verbundene
   Funktionalitaet aendert.