Zum Hauptinhalt springen

RFC 9530 - Digest-Felder (Digest Fields)

  • Status: Proposed Standard
  • Veröffentlicht: February 2024
  • Stream: IETF
  • Ersetzt: RFC3230
  • Errata: Keine Errata

Zusammenfassung​

Dieses Dokument definiert HTTP-Felder, die Integritäts-Digests unterstützen. Das Content-Digest-Feld kann für die Integrität von HTTP-Nachrichteninhalt verwendet werden. Das Repr-Digest-Feld kann für die Integrität von HTTP-Repräsentationen verwendet werden. Want-Content-Digest und Want-Repr-Digest können verwendet werden, um das Interesse und die Präferenzen eines Absenders für den Empfang der jeweiligen Integritätsfelder anzuzeigen.

Dieses Dokument macht RFC 3230 und die Digest- und Want-Digest-HTTP-Felder obsolet.

Status dieses Memos​

Dies ist ein Internet-Standards-Track-Dokument.

Dieses Dokument ist ein Produkt der Internet Engineering Task Force (IETF). Es stellt den Konsens der IETF-Gemeinschaft dar. Es wurde öffentlich überprüft und von der Internet Engineering Steering Group (IESG) zur Veröffentlichung genehmigt. Weitere Informationen zu Internet-Standards finden Sie in Abschnitt 2 von RFC 7841.

Informationen zum aktuellen Status dieses Dokuments, etwaige Errata und Möglichkeiten, Feedback dazu zu geben, erhalten Sie unter https://www.rfc-editor.org/info/rfc9530.

Urheberrechtshinweis​

Copyright (c) 2024 IETF Trust und die als Dokumentautoren identifizierten Personen. Alle Rechte vorbehalten.

Dieses Dokument unterliegt BCP 78 und den rechtlichen Bestimmungen des IETF Trust in Bezug auf IETF-Dokumente (https://trustee.ietf.org/license-info), die zum Zeitpunkt der Veröffentlichung dieses Dokuments gelten. Bitte lesen Sie diese Dokumente sorgfältig durch, da sie Ihre Rechte und Einschränkungen in Bezug auf dieses Dokument beschreiben. Code-Komponenten, die aus diesem Dokument extrahiert wurden, müssen den Text der überarbeiteten BSD-Lizenz enthalten, wie in Abschnitt 4.e der rechtlichen Bestimmungen des Trust beschrieben, und werden ohne Gewährleistung bereitgestellt, wie in der überarbeiteten BSD-Lizenz beschrieben.