Zum Hauptinhalt springen

2. Terminology (Terminologie)

2. Terminology (Terminologie)​

Die Schlüsselwörter „MUST“, „MUST NOT“, „REQUIRED“, „SHALL“, „SHALL NOT“, „SHOULD“, „SHOULD NOT“, „RECOMMENDED“, „NOT RECOMMENDED“, „MAY“ und „OPTIONAL“ in diesem Dokument sind wie in BCP 14 [RFC2119] [RFC8174] beschrieben zu interpretieren, und zwar nur dann, wenn sie wie hier in Großbuchstaben erscheinen.

Dieses Dokument übernimmt Terminologie aus JWT [RFC7519] und COSE [RFC8152].

StringOrURI

Der Begriff „StringOrURI“ in dieser Spezifikation hat dieselbe Bedeutung und dieselben Verarbeitungsregeln wie der JWT-Begriff „StringOrURI“ in Abschnitt 2 von [RFC7519], mit der Ausnahme, dass er als CBOR-Textstring statt als JSON-Textstring dargestellt wird.

NumericDate

Der Begriff „NumericDate“ in dieser Spezifikation hat dieselbe Bedeutung und dieselben Verarbeitungsregeln wie der JWT-Begriff „NumericDate“ in Abschnitt 2 von [RFC7519], mit der Ausnahme, dass er als CBOR-Zahldatum gemäß Abschnitt 2.4.1 von [RFC7049] statt als JSON-Zahl dargestellt wird. Die Kodierung ist so angepasst, dass das führende Tag 1 (epochenbasiertes Datum/Uhrzeit) weggelassen werden MUSS.

Claim Name

Der menschenlesbare Name zur Identifizierung eines Claims.

Claim Key

Der CBOR-Map-Schlüssel zur Identifizierung eines Claims.

Claim Value

Der CBOR-Map-Wert, der den Wert des Claims darstellt.

CWT Claims Set

Die CBOR-Map, die die vom CWT vermittelten Claims enthält.