Zum Hauptinhalt springen

3. Aktualisierungen von RFCs

3.1. Aktualisierungen von RFC 1034​

Dieses Dokument klärt mögliche Mehrdeutigkeiten in [RFC1034], die nicht klar zwischen Namen leerer Nicht-Endknoten (Empty Non-Terminal, ENT) ([RFC7719]) und nicht existierenden Namen unterschieden, und verweist auf nachfolgende Dokumente, die dies tun. ENTs sind Knoten im DNS, denen keine Ressourcendatensatzgruppen zugeordnet sind, die aber Nachkommenknoten haben, denen welche zugeordnet sind. Die korrekte Antwort auf ENTs ist NODATA (d. h. ein Antwortcode von NOERROR und ein leerer Antwortabschnitt). Zusätzliche klärende Formulierungen zu diesen Punkten finden sich in Abschnitt 7.16 von [RFC2136] sowie in den Abschnitten 2.2.2 und 2.2.3 von [RFC4592].

3.2. Aktualisierungen von RFC 2308​

Der zweite Absatz von Abschnitt 5 in [RFC2308] lautet wie folgt:

Eine negative Antwort, die aus einem Namensfehler (NXDOMAIN) resultierte, sollte so zwischengespeichert werden, dass sie abgerufen und als Antwort auf eine weitere Anfrage für dasselbe <QNAME, QCLASS> zurückgegeben werden kann, das die zwischengespeicherte negative Antwort verursacht hat.

Dieses Dokument ändert diesen Absatz wie folgt:

Eine negative Antwort, die aus einem Namensfehler (NXDOMAIN) resultierte, sollte so zwischengespeichert werden, dass sie abgerufen und als Antwort auf eine weitere Anfrage für dasselbe <QNAME, QCLASS> zurückgegeben werden kann, das die zwischengespeicherte negative Antwort verursacht hat, oder wenn der QNAME ein Nachkomme des ursprünglichen QNAME ist und die QCLASS dieselbe ist.

Abschnitt 2 oben erläutert die geänderte Regel und legt fest, wann es sinnvoll sein kann, sie zu lockern oder zu ignorieren.