Zum Hauptinhalt springen

1. Einführung

Dieses Dokument definiert das "Basic" Hypertext Transfer Protocol (HTTP) Authentifizierungsschema, das Anmeldeinformationen als Benutzer-ID/Passwort-Paare überträgt, die mit Base64 kodiert sind (HTTP-Authentifizierungsschemata sind in [RFC7235] definiert).

Dieses Schema wird nicht als sichere Methode zur Benutzerauthentifizierung angesehen, es sei denn, es wird in Verbindung mit einem externen Sicherheitssystem wie TLS (Transport Layer Security, [RFC5246]) verwendet, da die Benutzer-ID und das Passwort als Klartext über das Netzwerk übertragen werden.

Das "Basic"-Schema wurde zuvor in Abschnitt 2 von [RFC2617] definiert. Dieses Dokument aktualisiert diese Definition und behandelt auch Internationalisierungsprobleme durch Einführung des 'charset' Authentifizierungsparameters (Abschnitt 2.1).

Weitere Dokumente, die RFC 2617 aktualisieren, umfassen "Hypertext Transfer Protocol (HTTP/1.1): Authentication" ([RFC7235], das den Authentifizierungs-Framework definiert), "HTTP Digest Access Authentication" ([RFC7616], das die Definition des "Digest"-Authentifizierungsschemas aktualisiert) und "HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields" ([RFC7615]). Zusammengenommen machen diese vier Dokumente RFC 2617 obsolet.

1.1. Terminologie und Notation​

Die Schlüsselwörter "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" und "OPTIONAL" in diesem Dokument sind wie in [RFC2119] beschrieben zu interpretieren.

Die Begriffe "protection space" und "realm" sind in Abschnitt 2.2 von [RFC7235] definiert.

Die Begriffe "(character) repertoire" und "character encoding scheme" sind in Abschnitt 2 von [RFC6365] definiert.