Zum Hauptinhalt springen

RFC 7518 - JSON Web Algorithms (JWA)

  • Status: Proposed Standard
  • Veröffentlicht: May 2015
  • Stream: IETF
  • Errata: Keine Errata

Zusammenfassung (Abstract)​

Diese Spezifikation registriert kryptografische Algorithmen und Identifikatoren zur Verwendung mit den Spezifikationen JSON Web Signature (JWS), JSON Web Encryption (JWE) und JSON Web Key (JWK). Sie definiert mehrere IANA-Register für diese Identifikatoren.


Inhaltsverzeichnis (Contents)​

Anhänge (Appendices)​


Zugehörige Ressourcen​

JOSE-Spezifikationsreihe​

  • RFC 7515 - JSON Web Signature (JWS)
  • RFC 7516 - JSON Web Encryption (JWE)
  • RFC 7517 - JSON Web Key (JWK)
  • RFC 7518 - JSON Web Algorithms (JWA) ← Dieses Dokument
  • RFC 7519 - JSON Web Token (JWT)

Übersicht der Hauptalgorithmen​

Digitale Signatur- und MAC-Algorithmen​

  • HS256, HS384, HS512 - HMAC mit SHA-2
  • RS256, RS384, RS512 - RSASSA-PKCS1-v1_5
  • ES256, ES384, ES512 - ECDSA
  • PS256, PS384, PS512 - RSASSA-PSS
  • none - Kein Integritätsschutz (nicht empfohlen)

Schlüsselverwaltungsalgorithmen​

  • RSA1_5, RSA-OAEP, RSA-OAEP-256 - RSA-Schlüsselverschlüsselung
  • A128KW, A192KW, A256KW - AES-Schlüsselumhüllung
  • dir - Direkte Verwendung eines gemeinsamen symmetrischen Schlüssels
  • ECDH-ES, ECDH-ES+A128KW, ECDH-ES+A192KW, ECDH-ES+A256KW - ECDH-Schlüsselvereinbarung
  • A128GCMKW, A192GCMKW, A256GCMKW - AES GCM-Schlüsselverschlüsselung
  • PBES2-HS256+A128KW, PBES2-HS384+A192KW, PBES2-HS512+A256KW - Passwortbasierte Schlüsselverschlüsselung

Inhaltsverschlüsselungsalgorithmen​

  • A128CBC-HS256, A192CBC-HS384, A256CBC-HS512 - AES CBC mit HMAC SHA-2
  • A128GCM, A192GCM, A256GCM - AES GCM