RFC 9975 - Clarifications on CDS/CDNSKEY and CSYNC Consistency
- Status: Proposed Standard
- Published: May 2026
- Stream: IETF
- Updates: RFC 7344, RFC 7477
- Errata: No Errata
Abstract
Maintenance of DNS delegations requires occasional changes of the DS and NS record sets on the parent side of the delegation. This document specifies when target states expressed via CDS/CDNSKEY and CSYNC records are considered consistent, and updates RFCs 7344 and 7477.
Contents
- 1. Introduction
- 1.1. Requirements Notation
- 1.2. Terminology
- 2. Updates to RFCs 7344 and 7477
- 3. Processing Requirements
- 3.1. CDS and CDNSKEY
- 3.2. CSYNC
- 4. IANA Considerations
- 5. Security Considerations
- 6. References
- Appendix A. Failure Scenarios due to Inconsistencies
- Acknowledgments
- Author's Address
Related Resources
- Official Text: RFC 9975
- Official Page: RFC 9975 DataTracker
- Errata: RFC Editor Errata