4. 運用
4.1. 入力フィルタリング
すべてのIPv6ノードがRH0のサポートを削除するように更新されるまでには時間がかかることが予想されます。[CanSecWest07]で説明されているRH0の一部の使用法は、[RFC2827]および[RFC3704]で推奨されているように、入力フィルタリングによって緩和できます。
RH0を利用した攻撃から保護することを目的としたサイトのセキュリティポリシーは、サイトの境界での入力フィルタリングの実装を含めるべきです (SHOULD)。
4.2. ファイアウォールポリシー
タイプ0を特定してブロックし、他のタイプを許可するのではなく、ルーティングヘッダーを運ぶすべてのIPv6パケットをブロックすることは、IPv6の将来の発展に非常に重大な影響を及ぼします。配備されたファイアウォールのわずかな割合でも、他のタイプのルーティングヘッダーをデフォルトでブロックするようになれば、実際にはIPv6ルーティングヘッダーを拡張することが不可能になります。たとえば、モバイルIPv6 [RFC3775]はタイプ2ルーティングヘッダーに依存しています。ルーティングヘッダーの大規模で無差別なブロックは、モバイルIPv6を配備不可能にします。
RH0を含むパケットから保護することを目的としたファイアウォールポリシーは、ルーティングヘッダーを持つすべてのトラフィックを単にフィルタリングしてはなりません (MUST NOT)。他のタイプのルーティングヘッダーをブロックせずに、タイプ0トラフィックの転送を無効にできる必要があります。さらに、デフォルト設定は、0以外のルーティングヘッダーを使用するトラフィックの転送を許可しなければなりません (MUST)。