メインコンテンツまでスキップ

6. IANA Considerations (IANA に関する考慮事項)

6. IANA Considerations (IANA に関する考慮事項)​

この文書は, Internet Assigned Numbers Authority (IANA) によって管理される複数のレジストリを定義します。このセクションでは, これらのレジストリとそれらから値を割り当てるためのポリシーについて説明します。

6.1. Security Models (セキュリティモデル)​

SNMP アーキテクチャは複数のセキュリティモデルを許可します。各セキュリティモデルは一意の securityModel 値によって識別されます。securityModel 値の割り当ては IANA によって管理されます。

securityModel 値は 0 から 2147483647 の範囲の INTEGER です。

値は次のように割り当てられます:

値の範囲割り当てポリシー説明
0予約済みセキュリティモデルを識別しない
1Standards ActionSNMPv1 セキュリティモデル
2Standards ActionSNMPv2c セキュリティモデル
3Standards Actionユーザーベースセキュリティモデル (USM)
4-255Standards Action標準追跡セキュリティモデル用に予約
256+First Come First Servedエンタープライズ固有のセキュリティモデル

Standards Actionは, この範囲の値が IESG によって承認された RFC の公開を通じてのみ割り当てられることを意味します。

First Come First Servedは, この範囲の値がエンタープライズ ID に基づいてエンタープライズに割り当てられることを意味します。式は次のとおりです:

securityModel = (enterpriseID * 256) + security model within enterprise

たとえば, エンタープライズ ID 1 がセキュリティモデルを定義し, これが 4 番目のセキュリティモデルである場合, 値は次のようになります:

securityModel = (1 * 256) + 4 = 260

現在の割り当て:

  • 0: 予約済み(any)
  • 1: SNMPv1 (RFC 3584)
  • 2: SNMPv2c (RFC 3584)
  • 3: ユーザーベースセキュリティモデル(USM) (RFC 3414)

6.2. Message Processing Models (メッセージ処理モデル)​

SNMP アーキテクチャは複数のメッセージ処理モデルを許可します。各メッセージ処理モデルは一意の messageProcessingModel 値によって識別されます。messageProcessingModel 値の割り当ては IANA によって管理されます。

messageProcessingModel 値は 0 から 2147483647 の範囲の INTEGER です。

値は次のように割り当てられます:

値の範囲割り当てポリシー説明
0Standards ActionSNMPv1 メッセージ処理
1Standards ActionSNMPv2c メッセージ処理
2Standards ActionSNMPv2u(歴史的, 未使用)
3Standards ActionSNMPv3 メッセージ処理
4-255Standards Action標準追跡メッセージ処理モデル用に予約
256+First Come First Servedエンタープライズ固有のメッセージ処理モデル

Standards Actionは, この範囲の値が IESG によって承認された RFC の公開を通じてのみ割り当てられることを意味します。

First Come First Servedは, この範囲の値がエンタープライズ ID に基づいてエンタープライズに割り当てられることを意味します。式は次のとおりです:

messageProcessingModel = (enterpriseID * 256) + model within enterprise

現在の割り当て:

  • 0: SNMPv1 (RFC 3584)
  • 1: SNMPv2c (RFC 3584)
  • 2: SNMPv2u(歴史的)
  • 3: SNMPv3 (RFC 3412)

6.3. SnmpEngineID Formats (SnmpEngineID 形式)​

snmpEngineID は SNMP エンジンを一意に識別するために使用されます。グローバルな一意性を保証するために, snmpEngineID 値には特定の形式が推奨されます。

snmpEngineID は 5 から 32 オクテットの OCTET STRING です。

最初の 4 オクテットは次のように定義されます:

オクテット1-4: エンタープライズ ID

最初のビットは残りのオクテットの形式を示します:

  • ビット1 = 0: 形式は:

    オクテット: [1-4: エンタープライズ ID] [5: 形式] [6-32: 形式固有]
  • ビット1 = 1: 形式は:

    オクテット: [1-4: IANA エンタープライズ番号] [5-32: エンタープライズ固有]

最初のオクテットの最初のビットが 0 である snmpEngineID 値の場合, 5 番目のオクテットは形式識別子です。現在, 次の形式が定義されています:

形式値説明
0予約済み, 未使用
1IPv4 アドレス(4 オクテット)
2IPv6 アドレス(16 オクテット)
3MAC アドレス(6 オクテット)
4管理的に割り当てられたテキスト(0-27 オクテット)
5管理的に割り当てられたオクテット(0-27 オクテット)
6-127予約済み, 未使用
128-255エンタープライズ固有の形式

形式の例:

  1. 形式1 (IPv4 アドレス):

    [0-3: エンタープライズ ID (ビット1 = 0)]
    [4: 0x01]
    [5-8: IPv4 アドレス]
  2. 形式2 (IPv6 アドレス):

    [0-3: エンタープライズ ID (ビット1 = 0)]
    [4: 0x02]
    [5-20: IPv6 アドレス]
  3. 形式3 (MAC アドレス):

    [0-3: エンタープライズ ID (ビット1 = 0)]
    [4: 0x03]
    [5-10: MAC アドレス]
  4. 形式4 (テキスト):

    [0-3: エンタープライズ ID (ビット1 = 0)]
    [4: 0x04]
    [5-31: 管理的に割り当てられたテキスト]
  5. 形式5 (オクテット):

    [0-3: エンタープライズ ID (ビット1 = 0)]
    [4: 0x05]
    [5-31: 管理的に割り当てられたオクテット]

要件:

  • snmpEngineID 値は管理ドメイン内で一意でなければなりません
  • snmpEngineID 値は再起動後も一定のままでなければなりません
  • snmpEngineID 値は不揮発性ストレージに保存されるべきです
  • snmpEngineID 値はすべてゼロであってはなりません
  • snmpEngineID 値はすべて0xFF(すべてのビットが設定)であってはなりません
  • snmpEngineID 値は空(ゼロ長)であってはなりません

推奨事項:

  • 形式 1, 2, または 3 を使用する場合, アドレスはデバイスに永続的に割り当てられたものであるべきです
  • 形式 4 または 5 を使用する場合, 値は一意性を保証する方法で管理的に割り当てられるべきです
  • デバイスに複数の SNMP エンジンがある場合, それぞれが一意の snmpEngineID を持たなければなりません

IANA アクション:

IANA は snmpEngineID 形式値(形式識別子オクテット)のレジストリを維持します。6-127 の範囲の新しい形式値には Standards Action が必要です。128-255 の範囲の形式値は, 登録なしでエンタープライズ固有の使用に利用できます。