Passa al contenuto principale

1. Introduzione

Questa sezione conserva il testo della RFC su DHCPv6, inclusi scambi di messaggi, comportamento dei relay, DUID, IA_NA, IA_TA, IA_PD, opzioni DHCP, autenticazione RKAP, registri IANA, requisiti normativi e matrici in appendice sull'apparizione delle opzioni.

Testo originale della RFC​

1.  Introduzione

   Questo documento specifica DHCP per IPv6 (DHCPv6), un protocollo
   client/server che fornisce configurazione gestita dei dispositivi.  Il
   funzionamento di base di DHCPv6 fornisce configurazione ai client
   collegati allo stesso link del server.  Viene definita anche la
   funzionalita di relay agent per abilitare la comunicazione tra client
   e server che non si trovano sullo stesso link.

   DHCPv6 puo fornire a un dispositivo indirizzi assegnati da un server
   DHCPv6 e altre informazioni di configurazione; questi dati sono
   trasportati in opzioni.  DHCPv6 puo essere esteso tramite la
   definizione di nuove opzioni per trasportare informazioni di
   configurazione non specificate in questo documento.

   DHCPv6 supporta anche un meccanismo per la delega automatizzata di
   prefissi IPv6.  Tramite questo meccanismo, un server puo delegare
   prefissi ai client.  L'uso di questo meccanismo e specificato come
   parte di [RFC7084] e da [TR-187].  Si noti che quei documenti usano
   "requesting router" e "delegating router" dove questo documento usa
   rispettivamente "client" e "server".

   DHCP puo anche essere usato solo per fornire altre opzioni di
   configurazione (cioe, nessun indirizzo o prefisso).  Cio implica che
   il server non debba tenere traccia di alcuno stato; pertanto questa
   modalita e chiamata "stateless DHCPv6".  I meccanismi necessari per
   supportare stateless DHCPv6 sono molto piu semplici dei meccanismi
   necessari per supportare stateful DHCPv6.

1.1.  Relazione con i precedenti standard DHCPv6

   [RFC8415] forniva una definizione unificata, corretta e ripulita di
   DHCPv6 che copriva anche tutti gli errata applicabili presentati per
   RFC piu vecchie al momento della sua stesura.  Ha anche reso obsoleti
   un piccolo numero di meccanismi: autenticazione ritardata, lifetime e
   suggerimenti sui timer inviati da un client.

   Questo documento rende obsoleto [RFC8415].  Applica rapporti errata
   verificati e rende obsolete due funzionalita che non sono state
   ampiamente implementate - l'assegnazione di indirizzi temporanei
   usando l'opzione IA_TA e la possibilita per i client di inviare in
   unicast alcuni messaggi direttamente al server se il server ha inviato
   l'opzione Server Unicast a un client in uno scambio iniziale.
   Chiarisce inoltre le porte UDP usate da client, server e relay agent
   (Section 7.2).  Vedere Appendix A per un elenco delle differenze
   rispetto a [RFC8415].

1.2.  Argomenti fuori ambito

   Questo documento specifica il comportamento di DHCPv6.  La politica
   del server, ad esempio quali opzioni assegnare a quali client, quali
   subnet o pool di risorse usare, quali richieste dei client debbano
   essere negate, ecc., non rientra nell'ambito di questo documento.

   Anche configurazione, funzionamento e gestione del server sono fuori
   ambito.  Un approccio per gestire relay e server DHCPv6 e specificato
   in [RFC9243].

   La fusione della configurazione DHCPv4 [RFC2131] e DHCPv6 non rientra
   nell'ambito di questo documento.  [RFC4477] discute alcuni problemi e
   possibili strategie per eseguire insieme servizi DHCPv4 e DHCPv6.
   Sebbene [RFC4477] sia un po datato, fornisce una buona panoramica dei
   problemi in questione.  Il consenso dell'IETF al momento della
   stesura e che DHCPv4 debba essere usato invece di DHCPv6 quando si
   trasmettono informazioni di configurazione IPv4 ai nodi.  Per reti
   IPv6-only, [RFC7341] descrive un meccanismo di trasporto per portare
   messaggi DHCPv4 usando DHCPv6 per il provisioning dinamico
   dell'indirizzo IPv4 e delle informazioni di configurazione.