Aller au contenu principal

1. Introduction (Introduction)

1. Introduction (Introduction)​

RC4 est un chiffrement de flux décrit dans [SCH] ; il est largement pris en charge et souvent préféré par les serveurs TLS. Cependant, RC4 est connu depuis longtemps pour avoir diverses faiblesses cryptographiques, voir par exemple [PAU], [MAN] et [FLU]. Des résultats récents de cryptanalyse [ALF] exploitent des biais dans le flux de clés RC4 pour récupérer des textes clairs chiffrés de manière répétée.

Ces résultats récents sont sur le point de devenir pratiquement exploitables ; actuellement, ils nécessitent 2^26 sessions ou 13x2^30 chiffrements. En conséquence, RC4 ne peut plus être considéré comme offrant un niveau de sécurité suffisant pour les sessions TLS.

Ce document exige que les clients et serveurs TLS ([RFC5246] [RFC4346] [RFC2246]) ne négocient jamais l'utilisation de suites de chiffrement RC4.

1.1. Requirements Language (Langage des exigences)​

Les mots clés "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", et "OPTIONAL" dans ce document doivent être interprétés comme décrit dans la [RFC2119].