Zum Hauptinhalt springen

1. Introduction (Einführung)

1. Introduction (Einführung)​

RC4 ist eine in [SCH] beschriebene Stromchiffre; sie wird weithin unterstützt und häufig von TLS-Servern bevorzugt. Es ist jedoch seit langem bekannt, dass RC4 eine Vielzahl kryptografischer Schwächen aufweist, siehe z. B. [PAU], [MAN] und [FLU]. Jüngste Ergebnisse der Kryptoanalyse [ALF] nutzen Verzerrungen im RC4-Schlüsselstrom aus, um wiederholt verschlüsselte Klartexte wiederherzustellen.

Diese jüngsten Ergebnisse stehen kurz davor, praktisch ausnutzbar zu werden; derzeit erfordern sie 2^26 Sitzungen oder 13x2^30 Verschlüsselungen. Infolgedessen kann RC4 nicht mehr als ausreichend sicher für TLS-Sitzungen angesehen werden.

Dieses Dokument verlangt, dass TLS-Clients und -Server ([RFC5246] [RFC4346] [RFC2246]) unter keinen Umständen die Verwendung von RC4-Verschlüsselungssammlungen aushandeln.

1.1. Requirements Language (Anforderungssprache)​

Die Schlüsselwörter "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" und "OPTIONAL" in diesem Dokument sind so zu interpretieren, wie in [RFC2119] beschrieben.